Bug 1070849 - [Setup] on reinstall password appears in clear text in the log.
Summary: [Setup] on reinstall password appears in clear text in the log.
Keywords:
Status: CLOSED DUPLICATE of bug 1072476
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-27 15:23 UTC by Yaniv Lavi
Modified: 2014-07-13 23:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-04 16:54:14 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Logs (2.43 MB, text/x-log)
2014-02-27 15:25 UTC, Yaniv Lavi
no flags Details

Description Yaniv Lavi 2014-02-27 15:23:31 UTC
Description of problem:
After local engine-cleanup hitory db is cleaned, but not used in reinstall.
The conf file containing the db credentials is removed in the cleanup.
When the new user is created, password appears in clear text.

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
always

Steps to Reproduce:
1. run otopi setup with dwh plugin
2. run cleanup
3. reinstall.

Actual results:
new user is created, password appears in clear text.

Expected results:
if new user is created, password should not appear in clear text.

Additional info:
2014-02-27 13:55:00 DEBUG otopi.ovirt_engine_setup.database database.execute:132 Database: 'template1', Statement: '
                    create role ovirt_engine_history_20140227135500
                    with
                        login
                        encrypted password %(password)s
                ', args: {'password': 'n8rwkK7J'}

Comment 1 Yaniv Lavi 2014-02-27 15:25:58 UTC
Created attachment 868583 [details]
Logs

Comment 2 Alon Bar-Lev 2014-03-04 16:54:14 UTC

*** This bug has been marked as a duplicate of bug 1072476 ***


Note You need to log in before you can comment on or make changes to this bug.