Bug 1072476 - provisioning with existing database 'engine' logs the new password
Summary: provisioning with existing database 'engine' logs the new password
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
: 1070849 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-03-04 16:09 UTC by Yedidyah Bar David
Modified: 2014-03-31 12:26 UTC (History)
9 users (show)

Fixed In Version: ovirt-engine-3.4.0_rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:26:20 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25347 0 None MERGED packaging: setup: database: suppress password based on env key Never
oVirt gerrit 25378 0 None MERGED packaging: setup: database: suppress password based on env key Never
oVirt gerrit 25379 0 None MERGED packaging: setup: database: suppress password based on env key Never

Description Yedidyah Bar David 2014-03-04 16:09:20 UTC
Description of problem:

If an existing 'engine' db is found and we decide to create a new user/db engine_TIMESTAMP, we log the new password.

Comment 1 Alon Bar-Lev 2014-03-04 16:48:12 UTC
Please attach logs, I cannot reproduce this.

Anyway, I provide a fix of potential, please verify.

Comment 2 Alon Bar-Lev 2014-03-04 16:54:14 UTC
*** Bug 1070849 has been marked as a duplicate of this bug. ***

Comment 3 Alon Bar-Lev 2014-03-05 15:46:07 UTC
 Itamar Heim 2014-03-05 10:43:48 EST
Target Release: 3.4.0 → 3.4.1

Why?

Comment 4 Pavel Stehlik 2014-03-18 15:04:03 UTC
ok - av3 (rhevm d/s)

Comment 5 Sandro Bonazzola 2014-03-31 12:26:20 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.