Bug 107092 - Anaconda crashes with an unhandled exception while searching for packages to upgrade
Anaconda crashes with an unhandled exception while searching for packages to ...
Status: CLOSED DUPLICATE of bug 106965
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 18:19 EDT by Ben Steeves
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt file from the last crash (597.91 KB, text/plain)
2003-10-14 18:20 EDT, Ben Steeves
no flags Details

  None (edit)
Description Ben Steeves 2003-10-14 18:19:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728
Mozilla Firebird/0.6.1

Description of problem:
Anaconda crashes with an unhandled exception during an upgrade to FC0.95 from
FC0.94.  The anaconda dump is included. 

This crash happened on two machines -- one an Athlon 1800+, the other a Celeron
400.  The top of the dump from the Athlon is included here (e-mail me if you
want the whole thing).

I haven't tried any other installation methods.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to upgrade FC0.95 via NFS

Actual Results:  Installer crashes

Expected Results:  Installer should not crash

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int
 
Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x8d753ec>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.py'>
instPath: /mnt/sysimage
package: <rpm.hdr object at 0x89f9588>
h: <rpm.hdr object at 0xaa8b338>
mi: <rpm.mi object at 0xaa8ca48>
ts: <rpm.ts object at 0xaa8a390>
method: <image.NfsInstallMethod instance at 0x87bacd4>
myarch: i386
currentVersion: 0.94
hasX: 1
file: __db.003
supportedUpgradeVersion: -1
release: 1
found: 0
packages: [<rpm.hdr object at 0x92fd818>, <rpm.hdr object at 0x8a6a960>,
<rpm.hdr object at 0x8d5d0f0>, <rpm.hdr object at 0x8e67628>, <rpm.hdr object at
0x8b11f90>, <rpm.hdr object at 0x89fcb58>, <rpm.hdr object at 0x89f3668>,
<rpm.hdr object at 0x89f9588>]
win: <gui.WaitWindow instance at 0xaa71c24>
id: <instdata.InstallData instance at 0x8d71d4c>
dir: 1
Comment 1 Ben Steeves 2003-10-14 18:20:31 EDT
Created attachment 95179 [details]
anacdump.txt file from the last crash
Comment 2 Jeremy Katz 2003-10-14 19:47:11 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.