Bug 107102 - Unable to configure ISDN, crash at save the new configuration
Unable to configure ISDN, crash at save the new configuration
Status: CLOSED DUPLICATE of bug 107706
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
rawhide
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 20:35 EDT by Uwe Beck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback 1 (1.38 KB, text/plain)
2003-10-14 20:37 EDT, Uwe Beck
no flags Details
traceback 2 (1.22 KB, text/plain)
2003-10-14 20:38 EDT, Uwe Beck
no flags Details
Trace for activate new provider (1.76 KB, text/plain)
2003-10-27 18:53 EST, Uwe Beck
no flags Details

  None (edit)
Description Uwe Beck 2003-10-14 20:35:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [de] (X11; U; Linux 2.4.22-1.2088.nptl i686)

Description of problem:
I configure the AVM PCI (Fritz!PCI v2) ISDN-card and a provider with
redhat-config-network. It is not possible to save the configuration because
redhat-config-network crashes with traceback.

If you have the configfiles from an older Red Hat and know the places of them,
you can configure ISDN and it works.
The problem is not in versionen before.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.7-1

How reproducible:
Always

Steps to Reproduce:
1. Use redhat-config-network to configure ISDN-Card and Provider
2. Save the configuration
3.
    

Actual Results:  Unable to configure ISDN with redhat-config-network

Expected Results:  Be able to configure ISDN with redhat-config-network

Additional info:

See the traceback in the attachmets
Comment 1 Uwe Beck 2003-10-14 20:37:49 EDT
Created attachment 95181 [details]
traceback 1
Comment 2 Uwe Beck 2003-10-14 20:38:25 EDT
Created attachment 95182 [details]
traceback 2
Comment 3 Harald Hoyer 2003-10-22 06:48:46 EDT

*** This bug has been marked as a duplicate of 107706 ***
Comment 4 Uwe Beck 2003-10-27 18:53:46 EST
Created attachment 95536 [details]
Trace for activate new provider
Comment 5 Uwe Beck 2003-10-27 18:56:07 EST
With redhat-config-network-1.3.8-1 I can configure ISDN and save the
configuration.
It is not possible to activate the new provider. You can close the new open
With redhat-config-network-1.3.8-1 I can configure ISDN and save the
configuration.
It is not possible to activate the new provider. You can close the new open
windows. If you activate it again "an unhandled exeption has occured" -> see
attachment.
The reason could be:

argv: ['/usr/sbin/isdndial', 'ippp0']
closefd: -1

There is no /usr/sbin/isdndial on system. Is this a new program? I see that Than
Ngo has fixed the function "Activate".

It is an absolute requirement that the configfile is called ifcfg-ippp0. Some
programs such kisdndock only work with ifcfg-ippp0 convention together.
The name you give first for provider is shown as "Nickname" in
redhat-config-network. It is use for name by saving (ifcfg-"Nickname") in
/etc/sysconfig/network-scripts. If Nickname=ippp0 all is OK.
My providername is "brickxmp". In ifcfg-ippp0 there is "PROVIDER=brickxmp" an
this is use  for kisdndock.
Because my providername is "brickxmp" (ifcfg-brickxmp) at boot the
ISDN-interface is aktivate before eth0. If eth0 become active the default
gateway setting from ISDN is overwritten.
This all is no problem and works correct, if the ISDN-configfile calls
ifcfg-ippp0.
Comment 6 Ngo Than 2003-10-29 11:04:33 EST
Uwe, you should upgrade isdn4k-utils-3.2-5.p1 on your machine, it will fix
this problem.
Comment 7 Uwe Beck 2003-10-29 19:46:57 EST
The upgrade isdn4k-utils-3.2-5.p1 fix the problem with "Activate".

But it is an abolut requirement that the name of the ISDN configfile is
ifcfg-ipppx. Here are some reasons:

- kisdndock reads the configfile, if it called ifcfg-brickxmp (my provider is
"brickxmp" the color or kisdndock is grey and it does not work
- if there is in the ethernetcard configfile a default gateway, ISDN default
gateway can not overwrite the default gateway
  --> the interface brickxmp becomes active before ethx and the activation from
ethx overwrites the ISDN default gateway.
The problem is the identification of all network devices, I think it is in
network-functions. The result for this identification is an alphabetical list.
My providername is "brickxmp" and it is before "ethx".

- ifup ippp0 and ifdown ippp0 do not work
  --> need ifup/ifdown brickxmp and this is not the interfacename in the system
Comment 8 Red Hat Bugzilla 2006-02-21 13:59:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.