Bug 107124 - Upgrade failed from test2 -> test3
Summary: Upgrade failed from test2 -> test3
Status: CLOSED DUPLICATE of bug 106965
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 08:12 UTC by Michael Koziarski
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump option (603.00 KB, text/plain)
2003-10-15 08:14 UTC, Michael Koziarski
no flags Details

Description Michael Koziarski 2003-10-15 08:12:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
Installer fails to update from test2 to test3.  After choosing to update
bootloader configuration I get the following python error:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1120, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 474, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

The discs passed the mediatest, and I tried both the CD and DVD drives in this
PC.  I get the same error with graphical and text mode.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot disc1 to begin upgrade process.
2. Choose to upgrade rather than reinstall
3. Select relevant hardware options
4. Choose to update configuration
    

Actual Results:  Installer pops up the error above, gives me options to save to
disk or reboot.  Installation doesn't proceed

Expected Results:  Whatever the next step is

Additional info:

Comment 1 Michael Koziarski 2003-10-15 08:14:24 UTC
Created attachment 95190 [details]
Anaconda dump option

This is the dump that the installer let me save to floppy.

It is from one of the text installation attempts

Comment 2 Jens Petersen 2003-10-15 10:37:37 UTC
I had ran into this too when trying to update my laptop from test2 to test3.

Comment 3 Jeremy Katz 2003-10-15 16:40:29 UTC

*** This bug has been marked as a duplicate of 106965 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:59:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.