Bug 107136 - kudzu want to add generic PS/2 mouse after plugging in usb mouse
kudzu want to add generic PS/2 mouse after plugging in usb mouse
Status: CLOSED DUPLICATE of bug 107679
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 07:25 EDT by Need Real Name
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-10-15 07:25:35 EDT
Description of problem:
On dell i8100 (and dell i8200) fedora core test 3 is installed using
only the touch pad. After plugging in a logitech usb wheel mouse some time
after install kudzu wants to add a Generic Mouse (PS/2) at each subsequent
reboot until told to ignore.
Both 'mice', the touch pad and the usb mouse, work OK


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2003-10-15 15:24:57 EDT
Is it consistent - if you re-run kudzu after unplugging the USB mouse, the PS/2
mouse appears to go away?
Comment 2 Need Real Name 2003-10-16 08:51:59 EDT
Is this what you intended:
1. boot laptop
2. unplug usb mouse
3. reboot laptop
I have done this 3 times and the kudzu message did not reappear.

I also did the following 3 times:
1) boot laptop
2) unplug usb mouse
3) reboot laptop
4) plug in usb mouse
5) reboot laptop
Again the Generic Mouse(PS/2) message did not reappear.

I also ran kudzu -p a couple of times in a console, again nothing.

After I had seen this kudzu message a couple of times (before bugzillaing it)
I told kudzu to 'ignore' it. Does this 'ignore' leave a persistent 'checkmark'
somewhere?

PS /etc/sysconfig/hwconf has an entry:
   'usbprod: USB-PS/2 Optical Mouse'.
Comment 3 Bill Nottingham 2003-10-16 13:56:45 EDT
Yes, 'ignore' leaves a permanent 'don't worry about this device' entry.

What does your /etc/sysconfig/hwconf look like?
Comment 4 Need Real Name 2003-10-21 09:39:00 EDT
It is very possible this kudzu message is NOT related to the usb mouse.

Yesterday I installed test3 on a dell inspiron 8200 without the usb mouse
plugged in. (the i8200 has an Alps GlidePoint/Stickpointer/Touchpad).
After install the stickpointer/touchpad worked perfectly and 'XF86Config' and
'hwconf' had the correct entries.

Without plugging in the usb mouse I rebooted the laptop.
Kudzu promptly came up with the same message that it wants to add a
Generic PS/2 mouse.

I have neither configured the mouse from the kudzu prompt nor 'ignored' it.
I have also not plugged in the usb mouse yet.
If you want me to test anything just ask.
Comment 5 Bill Nottingham 2003-10-22 17:39:50 EDT
This should be fixed when kudzu-1.1.35-1 is used in an install
environment.

*** This bug has been marked as a duplicate of 107679 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.