Bug 1071527 - tests failing on big endians
tests failing on big endians
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 1072014 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2014-03-01 05:39 EST by Dan Horák
Modified: 2014-03-04 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 14:03:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2014-03-01 05:39:27 EST
some tests are failing on big endian arches like ppc and s390

from build.log
...
make: Entering directory `/builddir/build/BUILD/strigi-0.7.8/s390-redhat-linux-gnu'
Running tests...
/usr/bin/ctest --force-new-ctest-process 
Test project /builddir/build/BUILD/strigi-0.7.8/s390-redhat-linux-gnu
      Start  1: Base64InputStreamTest
 1/25 Test  #1: Base64InputStreamTest ............   Passed    0.00 sec
      Start  2: SkippingFileInputStreamTest
 2/25 Test  #2: SkippingFileInputStreamTest ......   Passed    0.00 sec
      Start  3: MMapFileInputStreamTest
 3/25 Test  #3: MMapFileInputStreamTest ..........   Passed    0.00 sec
      Start  4: ArInputStreamTest
 4/25 Test  #4: ArInputStreamTest ................   Passed    0.00 sec
      Start  5: BZ2InputStreamTest
 5/25 Test  #5: BZ2InputStreamTest ...............   Passed    0.00 sec
      Start  6: CpioInputStreamTest
 6/25 Test  #6: CpioInputStreamTest ..............   Passed    0.00 sec
      Start  7: EventInputStreamTest
 7/25 Test  #7: EventInputStreamTest .............   Passed    0.00 sec
      Start  8: FileInputStreamTest
 8/25 Test  #8: FileInputStreamTest ..............   Passed    0.00 sec
      Start  9: GZipInputStreamTest
 9/25 Test  #9: GZipInputStreamTest ..............   Passed    0.00 sec
      Start 10: InputStreamReaderTest
10/25 Test #10: InputStreamReaderTest ............***Failed    0.00 sec
Invalid multibyte sequence.
test 'n2 > -2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:47
test 'size == n' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:56
error Invalid multibyte sequence.
test 's->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:61
test 'n > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:70
test 'n == p' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:72
Invalid multibyte sequence.
test 'n2 > -2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:41
test 'ptr' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:42
test 'size == n' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:56
error Invalid multibyte sequence.
test 's->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:61
test 'n == s->size()' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:86
test 'n == p' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:88
test 's->status() == Ok' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:89
test 'n2 == s->size()' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:92
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'memcmp(p1, p2, nread1*sizeof(wchar_t))==0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:74
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
test 'nread1 > 0' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:60
test 'nread1 == nread2' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/InputStreamReaderTest.cpp:72
      Start 11: InputStreamTest
11/25 Test #11: InputStreamTest ..................   Passed    0.00 sec
      Start 12: KmpSearcherTest
12/25 Test #12: KmpSearcherTest ..................   Passed    0.00 sec
      Start 13: LZMAInputStreamTest
13/25 Test #13: LZMAInputStreamTest ..............   Passed    0.00 sec
      Start 14: MailInputStreamTest
14/25 Test #14: MailInputStreamTest ..............   Passed    0.01 sec
      Start 15: OleInputStreamTest
15/25 Test #15: OleInputStreamTest ...............***Failed    0.00 sec
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
      Start 16: RpmInputStreamTest
16/25 Test #16: RpmInputStreamTest ...............***Failed    0.00 sec
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
RPM seems to be truncated or corrupted.
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
      Start 17: SdfInputStreamTest
17/25 Test #17: SdfInputStreamTest ...............   Passed    0.00 sec
      Start 18: StringTerminatedSubStreamTest
18/25 Test #18: StringTerminatedSubStreamTest ....   Passed    0.00 sec
      Start 19: SubInputStreamTest
19/25 Test #19: SubInputStreamTest ...............   Passed    0.00 sec
      Start 20: TarInputStreamTest
20/25 Test #20: TarInputStreamTest ...............   Passed    0.00 sec
      Start 21: ZipInputStreamTest
21/25 Test #21: ZipInputStreamTest ...............***Failed    0.00 sec
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
test 's' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:99
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:110
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
Error skipping extra field: 
test 'ssp->status() == Strigi::Eof' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/sharedtestcode/inputstreamtests.cpp:124
test 'i' failed at
	/builddir/build/BUILD/strigi-0.7.8/libstreams/tests/api/ZipInputStreamTest.cpp:42
      Start 22: ArchiveReaderTest
22/25 Test #22: ArchiveReaderTest ................   Passed    0.01 sec
      Start 23: ProcessInputStreamTest
23/25 Test #23: ProcessInputStreamTest ...........   Passed    0.00 sec
      Start 24: StringStreamTest
24/25 Test #24: StringStreamTest .................   Passed    0.00 sec
      Start 25: stat64bitTest
25/25 Test #25: stat64bitTest ....................   Passed    0.00 sec
84% tests passed, 4 tests failed out of 25
Total Test time (real) =   0.09 sec
The following tests FAILED:
	 10 - InputStreamReaderTest (Failed)
	 15 - OleInputStreamTest (Failed)
	 16 - RpmInputStreamTest (Failed)
	 21 - ZipInputStreamTest (Failed)
Errors while running CTest
make: *** [test] Error 8


for full logs please see
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1689802
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1358938


Version-Release number of selected component (if applicable):
strigi-0.7.8-4.fc21
Comment 1 Kevin Kofler 2014-03-03 12:32:48 EST
*** Bug 1072014 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2014-03-04 14:01:27 EST
I'll fix it up so these tests are no longer fatal...

should be mostly harmless, very little (in kde at least) actually uses this api anymore.
Comment 3 Rex Dieter 2014-03-04 14:03:58 EST
Let me know if you want this backported to anything < rawhide.

%changelog
* Tue Mar 04 2014 Rex Dieter <rdieter@fedoraproject.org> 0.7.8-5
- tests failing on big endians (#1071527)
Comment 4 Dan Horák 2014-03-04 17:12:50 EST
the tests are enabled only in rawhide, so no need for backports, thanks for the workaround

Note You need to log in before you can comment on or make changes to this bug.