Bug 107178 - Anaconda Exception Upgrade fails. Related to upgradeFindPackages?
Summary: Anaconda Exception Upgrade fails. Related to upgradeFindPackages?
Status: CLOSED DUPLICATE of bug 106965
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 17:45 UTC by stuart boreen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stuart boreen 2003-10-15 17:45:11 UTC
Description of problem:
Exception Occured in Anaconda -- can not upgrade from tes-2 to 3

Version-Release number of selected component (if applicable):
Whichever anaconda was in test-3

How reproducible:
100%

Steps to Reproduce:
1. Shrink NTFS on IBM T40, install severn2 with grub on /dev/hda6 (no boot
partition) Then it fails to boot from NT loader, use rescue mode to install on
/dev/hda. Runs well.
2.Try to upgrade to severn3 using boot CD and cd or hard disk for install
method. Use any option for boot loader: update, no update...
3.
    
Actual results:
After clicking on next on the Upgrade Boot Loader Config page, get fatal
Exception box, please file bug against anaconda

Expected results:
Keep going on the upgrade, choose packages and so forth.

Additional info: (from debug)
Traceback:
File /usr/lib/anaconda/gui.py line 766...
File dispatch.py line 168
File dispatch.py line 236
File "/usr/lib/anaconda/upgrade.py", line 530, in upgradedFindPackages
(h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

< p.s. how can I save the log or file from this upgrade attempt so I don't have
to manually type this stuff in. I do have a runnning Linux installation with a
/ext3 partition]

Comment 1 Jeremy Katz 2003-10-15 18:14:19 UTC

*** This bug has been marked as a duplicate of 106965 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.