Bug 107182 - Upgrade test2->test3 bombs in anaconda/upgrade.py
Upgrade test2->test3 bombs in anaconda/upgrade.py
Status: CLOSED DUPLICATE of bug 106965
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 13:54 EDT by Bob Lynch
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 16:08:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Lynch 2003-10-15 13:54:32 EDT
Description of problem: Using test3 iso's, when I upgrade from test2 -> test3,
anaconda bombs while trying to set up a package list

Version-Release number of selected component (if applicable):
Unknown

How reproducible:
Always happens

Steps to Reproduce:
1. Arrive at install by booting CD of iso1 
2. Answer English/US keyboard, ask for upgrade, then it bombs
3. Dump of upgrade.py python error shown below
    
Actual results: upgrade does not proceed, I am forced to reboot, with same result

Expected results: successful upgrade test2 -> test3

Additional info: Error output

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1120, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 474, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <text.InstallInterface instance at 0x8cc742c>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.py'>
instPath: /mnt/sysimage
package: <rpm.hdr object at 0x8f33de0>
h: <rpm.hdr object at 0xb0f2a80>
mi: <rpm.mi object at 0xb0f2a60>
ts: <rpm.ts object at 0xb0f23c0>
method: <image.CdromInstallMethod instance at 0x8df421c>
myarch: i386
currentVersion: 0.94
hasX: 1
file: __db.003
supportedUpgradeVersion: -1
release: 1.1
found: 0
Comment 1 Jeremy Katz 2003-10-15 14:13:26 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 2 Bob Lynch 2003-10-15 16:08:37 EDT
Resolved bug using the severn-t3-updates.img mentioned in dup bug 106965.
Install went successfully.

Note You need to log in before you can comment on or make changes to this bug.