Bug 107187 - firstboot uses US keyboard instead of the alien one asked in installation
Summary: firstboot uses US keyboard instead of the alien one asked in installation
Status: CLOSED DUPLICATE of bug 100686
Alias: None
Product: Fedora
Classification: Fedora
Component: rhgb   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 18:25 UTC by Jean Francois Martinez
Modified: 2013-04-02 04:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jean Francois Martinez 2003-10-15 18:25:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When I rebooted after installation I found firstboot was using the
US keyboard.  When it finished and gdm was started I found gdm was
using the correct, non-US keyboard.

This bug was present in all the previous betas.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Pick english as inatllation language
2. Select french keyboard for the install
3.  Complete install and reboot
    

Actual Results:  See aboove

Additional info:

Comment 1 Brent Fox 2003-10-15 18:27:46 UTC
firstboot should use whatever the keymap is specified in the XF86Config file. 
Can you attach that file?


Comment 2 Brent Fox 2003-10-15 18:36:00 UTC
Actually, nevermind.  This is an rhgb problem since rhgb is somehow defaulting
to a US keymap.  Since firstboot inherits rhgb's X server, it's picking up the
US keymap.  When firstboot ends, that X session dies and gdm starts up a new one
which pulls the correct keymap from the XF86Config file

Changing component to rhgb.

Comment 3 Brent Fox 2003-10-15 18:37:30 UTC

*** This bug has been marked as a duplicate of 100686 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:59:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.