Bug 100686 - keyboard not configured in firstboot
keyboard not configured in firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 101220 105659 107187 107209 107219 107232 107277 121931 121951 122302 123940 133952 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-24 08:22 EDT by Féliciano Matias
Modified: 2007-11-30 17:10 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 11:56:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Féliciano Matias 2003-07-24 08:22:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The keyboard is not configured in firstboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do a fresh install of RedHat Linux and select an azerty keyboard for example.


Actual Results:  Querty keyboard in firstboot.

Expected Results:  keyboard configured as selected in anaconda.

Additional info:
Comment 1 Brent Fox 2003-07-24 10:33:31 EDT
Does the keyboard work at all or is it just the wrong keymap?
Comment 2 Féliciano Matias 2003-07-24 17:23:03 EDT
When i hit the 'a' key i see a 'q' char on the screen.
The keyboard work. It should be a wrong keymap.
Comment 3 Bill Nottingham 2003-07-28 16:34:24 EDT
If you boot with 'nogui', and firstboot is run *that* way, does it work?
Comment 4 Féliciano Matias 2003-07-28 19:41:04 EDT
Fresh installation of severn. Append "nogui" to grub with anaconda installer. At
the first boot, firstboot program is launched and there is no keyboard problem.
Comment 5 Bill Nottingham 2003-07-28 21:13:38 EDT
I expected as much. When rhgb is running, firstboot inherits rhgb's X server;
howerver, XKB doesn't work right with rhgb's X server, due to the read-only file
system, or somesuch.
Comment 6 Brent Fox 2003-07-29 09:36:03 EDT
Changing component to rhgb.
Comment 7 Bill Nottingham 2003-07-30 09:59:17 EDT
*** Bug 101220 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2003-09-26 15:53:56 EDT
*** Bug 105659 has been marked as a duplicate of this bug. ***
Comment 9 Brent Fox 2003-10-15 14:37:34 EDT
*** Bug 107187 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2003-10-15 18:57:17 EDT
*** Bug 107219 has been marked as a duplicate of this bug. ***
Comment 11 Brent Fox 2003-10-15 18:58:01 EDT
*** Bug 107209 has been marked as a duplicate of this bug. ***
Comment 12 Brent Fox 2003-10-15 20:40:01 EDT
*** Bug 107232 has been marked as a duplicate of this bug. ***
Comment 13 Christian Rose 2003-10-15 21:05:09 EDT
Also happens with Fedora Core test 3.
Comment 14 Brent Fox 2003-10-16 11:53:04 EDT
*** Bug 107277 has been marked as a duplicate of this bug. ***
Comment 15 Jonathan Blandford 2003-10-16 13:04:25 EDT
I have a tentative fix for this.  Can people try:
http://people.redhat.com/jrb/files/rhgb-0.10.5-1.i386.rpm
Comment 16 Jonathan Blandford 2003-10-16 17:30:21 EDT
scratch that.  That's not going to work quite correctly.  I'll get another test
tomorrow.
Comment 17 Jonathan Blandford 2003-10-20 17:30:52 EDT
I am pretty sure I have this fixed in the latest rhgb/initscripts.
Comment 18 Douglas Peale 2004-05-02 17:33:48 EDT
*** Bug 122302 has been marked as a duplicate of this bug. ***
Comment 19 Féliciano Matias 2004-05-03 07:40:56 EDT
Reopen the bug.
appear again in FC2T3.
Comment 20 Luc Saillard 2004-05-10 04:55:31 EDT
I've the same problem with an azerty keyboard. When you add some user  
to the system, the keyboard is in qwerty. version FC2 Test3. 
Comment 21 Christian Rose 2004-05-18 17:57:41 EDT
The problem also appears in FC2 final.

This bug is especially problematic on the Add User screen. Full names
with non-ASCII characters cannot be entered correctly, and passwords
set may turn out to be wrong.
Because of the latter problem, which may cause an user to essentially
lock himself or herself out of the system, since the password set
won't be accepted later, I'm raising the severity to High.
Comment 22 marc frei 2004-05-23 20:56:30 EDT
I guess this bug give me the following behaviour (FC2 final with rhgb) :

I can't log within GDM if my user password is for instance "qwerty"
and the keyboard is supposed/known to be an "azerty" one....

In fact, you don't see what you type (*****) and I tested my keyboard
in the user/login field and this shown me that the keyboard is NOT the
"azerty" one before Gnome is fully started.

Once logged (after converting the passwords....), the "azerty"
keyboard is used : OK

So, this is definitivly "High" for users outside US.



Comment 23 Brent Fox 2004-05-24 14:59:00 EDT
*** Bug 121931 has been marked as a duplicate of this bug. ***
Comment 24 Brent Fox 2004-05-24 14:59:12 EDT
*** Bug 123940 has been marked as a duplicate of this bug. ***
Comment 25 Bernd Bartmann 2004-07-14 06:54:03 EDT
The bug still exists in FC3 Test1.
Comment 26 Daniel Veillard 2004-09-09 10:37:28 EDT
Okay, confirmed, reproduced ...
I knew I shouldn't have trashed my last azerty keyboard a few years
ago :-\

Daniel
Comment 27 Daniel Veillard 2004-09-11 17:21:26 EDT
As Bill rightly guessed in #5 the keyboard bindings set in the
X11 configuration file won't work because the keymap is generated 
at stratup and with a read-only file-system well it just doesn't
work. I implemented a workaround which resets the X11 keymap
dynamically when firstboot is about to be run, and it seems to work :-)

http://people.redhat.com/veillard/testing/Rawhide/i386/rhgb/0.12.6/

Daniel
Comment 28 Daniel Veillard 2004-09-13 12:37:22 EDT
*** Bug 121951 has been marked as a duplicate of this bug. ***
Comment 29 Daniel Veillard 2004-09-13 12:38:43 EDT
Version 0.12.6 was pushed on Rawhide and should fix this bug,

Daniel
Comment 30 Daniel Veillard 2004-09-28 13:48:59 EDT
*** Bug 133952 has been marked as a duplicate of this bug. ***
Comment 31 David Balažic 2004-11-15 08:14:00 EST
Fedora Core 3 has rhgb-0.14.1-1.i386.rpm and the bug is still there.

( I selected Slovenian layout in anaconda, but firstboot used US ( or
similar ) )

Reopening.
Comment 32 David Balažic 2004-11-15 08:15:19 EST
... and adding myself to CC ( sorry for spam )
Comment 33 Daniel Veillard 2004-11-15 08:23:23 EST
it works for other languages. What do you have in
/etc/sysconfig/keyboard ?
Also provide the subsection of your /etc/X11/xorg.conf
defining the keyboard.
This mean the lookup for *both* methods of Slovenian layout failed !

Daniel
Comment 34 David Balažic 2004-11-15 08:30:26 EST
I can't do that before tomorrow.

If it helps : At install I selected english install language,
Slovenian keyboard layout ( worked at once both in X and textual
console ) and some laguages for install ( english , Slovenian ,
Croatian, Hungarian and some more ).

After install in X the keyboard is Slovenian ( works OK ).
Comment 35 David Balažic 2004-11-16 01:43:41 EST
cat /etc/sysconfig/keyboard

KEYBOARDTYPE="pc"
KEYTABLE="slovene"

---------------------

/etc/X11/xorg.conf :

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "si"
EndSection
Comment 36 Daniel Veillard 2004-11-16 04:24:44 EST
How is rhgb supposed to understand that "slovene" means "si" ?
That's why it broke, for a french configured keyboard you get
something based on the ISO country name like "fr" or "fr_FR".
I think the generation of the KEYTABLE value is wrong, potentially
an anaconda bug... Can you reopen a new bug pointing to this,
addressing anaconda, with me in CarbonCopy ? I don't feel reassigning
this big bug history and list is the right way to handle that specific
problem.

  thanks,

Daniel
Comment 37 David Balažic 2005-04-21 08:22:22 EDT
I opened bug 155554 , Daniel.
Comment 38 John Thacker 2006-10-29 15:40:13 EST
So, I see that the associated bug 155554 is closed rawhide.  Is this bug fixed,
then?
Comment 39 Féliciano Matias 2006-10-29 23:41:02 EST
(In reply to comment #38)
> So, I see that the associated bug 155554 is closed rawhide.  Is this bug fixed,
> then?

Yes for me.
Comment 40 Bill Nottingham 2006-10-30 11:56:55 EST
Thanks, closing

Note You need to log in before you can comment on or make changes to this bug.