Bug 107221 - [rhgb] Network doesn't receive packets after dhcp, init scripts complete
[rhgb] Network doesn't receive packets after dhcp, init scripts complete
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 109616 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 18:22 EDT by Torrey Hoffman
Modified: 2013-07-02 22:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 00:38:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torrey Hoffman 2003-10-15 18:22:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807

Description of problem:
Installed Fedora Core Test 3 on an HP OmniBook 4150 which contains a Xircom
ethernet/modem card.  Networking does not work, as detailed below.  Red Hat 9 on
the same hardware worked.

The hardware was detected during the install, and after booting, the correct
modules load and DHCP succeeds.  However, after the system completes booting up,
the network does not work:

- /sbin/ifconfig correctly shows the DHCP-assigned IP, netmask, a small number
of packets sent and received.

- /etc/route -n displays correct-looking output

- pinging the gateway or other machines, (by IP address) returns "Destination
Host Unreachable".  And of course no other network applications work.

There are no interesting messages in the system logs.  "dmesg" contains:
xircom cardbus adaptor found, registering as eth0, using irq10
xircom_cb: Link status has changed
xircom_cb: Link is 100 mbit

Thinking that perhaps the firewall was to blame, I removed the
/etc/rc5.d/S08iptables symlink, shutdown and rebooted the machine.  Nothing
changed - DHCP worked, but nothing after that, just like before.

If (as root) I cd to /etc/init.d and do "./network restart", it shuts down eth0
and loopback, sets network parameters, brings up loopback, and then fails to
bring up interface eth0.

/proc/interrupts shows the following on irq 10 (usb-uhci, Texas Instruments
PCI1225, Texas Instruments PCI1225 (#2), ESS Maestro 2E)

(Should I be seeing the ethernet driver here?  Perhaps this is the problem?)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core Test 3 on an HP Omnibook 4150 with a Xircom PCMCIA
ethernet card
2. Choose the DHCP and Firewall Enabled options during install
3. Try to use the network after the install.
    

Actual Results:  DHCP works during boot.  After that, networking does not work.

Expected Results:  Networking should work :-)

Additional info:

Happy to provide more information or try anything, including kernel patches or
whatever...
Comment 1 Bill Nottingham 2003-10-15 18:35:18 EDT
This sounds like a driver problem.
Comment 2 Dave Jones 2003-10-16 11:39:39 EDT
A large bunch of network driver updates are pending for 2094. Give those a shot
when it turns up in rawhide
Comment 3 Torrey Hoffman 2003-10-28 20:09:55 EST
I tried updating the laptop to the 2.4.22-1.2110.nptl version of the kernel,
which was current as of October 28th, and that didn't help...
Comment 4 Elijah Newren 2003-11-07 13:05:01 EST
I'm experiencing the exact same problem with Fedora Core 1 (kernel
2.4.22-1.2115.nptl).  I can also verify that Red Hat 9 worked fine for
me.  I have a Dell Inpiron 8100 with a Xircom ethernet/modem card.

I asked for help from the sysadmin at school and after searching for a
while, he found that running

  cardctl eject 0

then waiting for a little while and then running

  cardctl insert 0

would get the ethernet connection up and running.  After he found
this, I went to post a bug to bugzilla, but found this bug already
entered.  So, I'm adding the info here.
Comment 5 Elijah Newren 2003-11-11 11:50:20 EST
More info:  This doesn't seem to happen on my home network, but it
does happen on the network at school...which seems really odd to me
since I'm using DHCP in both places.  Also, at school, I occasionally
have to re-run the above commands again throughout the day.  *shrugs*

Oh, and I left off one of the commands above.  After the two cardctl
commands, I always have to run an 'ifup eth0'.
Comment 6 Elijah Newren 2003-11-12 16:12:59 EST
More info: Bug 109616 is a duplicate of this bug and says that the bug
can be worked around by removing 'rhgb' from the kernel parameters at
boot.  This workaround works for me as well.
Comment 7 Aleksey Nogin 2004-01-07 00:10:12 EST
*** Bug 109616 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2004-12-07 00:38:42 EST
fc1 = eol

Note You need to log in before you can comment on or make changes to this bug.