Bug 1072549 - Schema upgrade failure on 03_05_0050_event_notification_methods.sql
Summary: Schema upgrade failure on 03_05_0050_event_notification_methods.sql
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Eli Mesika
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
: 1072866 (view as bug list)
Depends On:
Blocks: 1072867
TreeView+ depends on / blocked
 
Reported: 2014-03-04 18:26 UTC by Adam Litke
Modified: 2014-03-31 12:31 UTC (History)
5 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1072867 (view as bug list)
Environment:
Last Closed: 2014-03-31 12:31:10 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25376 None None None Never

Description Adam Litke 2014-03-04 18:26:54 UTC
I've recently rebased to master and it looks like the
03_05_0050_event_notification_methods.sql script is failing on schema
upgrade.  Is this a bug or am I doing something wrong?  To upgrade I
did the normal proceedure with my development installation:

make install-dev ...
~/ovirt/bin/engine-setup

Got this result in the log file:

psql:/home/alitke/ovirt-**FILTERED**/share/ovirt-**FILTERED**/dbscripts/upgrade/03_05_0050_event_notification_methods.sql:10: ERROR:  column "notification_method" contains null values
FATAL: Cannot execute sql command: --file=/home/alitke/ovirt-**FILTERED**/share/ovirt-**FILTERED**/dbscripts/upgrade/03_05_0050_event_notification_methods.sql

2014-03-03 17:20:34 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
 File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
   method['method']()
 File "/home/alitke/ovirt-**FILTERED**/share/ovirt-**FILTERED**/setup/bin/../plugins/ovirt-**FILTERED**-setup/ovirt-**FILTERED**/db/schema.py", line 280, in _misc
   osetupcons.DBEnv.PGPASS_FILE
 File "/usr/lib/python2.7/site-packages/otopi/plugin.py", line 451, in execute
   command=args[0],
RuntimeError: Command '/home/alitke/ovirt-**FILTERED**/share/ovirt-**FILTERED**/dbscripts/schema.sh' failed to execute

Version-Release number of selected component (if applicable):
faafbcf89fb1b236e228aa64c6143032d850a4fa

Comment 1 Eli Mesika 2014-03-05 10:17:26 UTC
moving that to 3.4 urgent  since any installation that have non-empty event_subscriber table (users that had subscribed to any event) will cause the upgrade to fail

Comment 2 Mooli Tayer 2014-03-05 10:38:00 UTC
*** Bug 1072866 has been marked as a duplicate of this bug. ***

Comment 3 Adam Litke 2014-03-05 13:34:46 UTC
Just curious, but since the script is 03_05_0050, it wont be released as part of 3.4.0, right?  Why is it important to target this to 3.4.0?

Comment 4 Eli Mesika 2014-03-05 13:40:20 UTC
(In reply to Adam Litke from comment #3)
> Just curious, but since the script is 03_05_0050, it wont be released as
> part of 3.4.0, right?  Why is it important to target this to 3.4.0?

Adam when we start 3.5 we change the prefix upstream to be 03_05 , however , some of those scripts are still 3.4 downstream related and if you look in the stable 3.4 you will see a 03_04_0600.... script that has this functionality

Comment 5 Sandro Bonazzola 2014-03-31 12:31:10 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.