Bug 1072866 - event_subscriber upgrade script fails on any user that has an event_subscriber record.
Summary: event_subscriber upgrade script fails on any user that has an event_subscribe...
Keywords:
Status: CLOSED DUPLICATE of bug 1072549
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-notificiations
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mooli Tayer
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-05 10:17 UTC by Mooli Tayer
Modified: 2014-03-05 10:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-05 10:38:00 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25372 0 None None None Never

Description Mooli Tayer 2014-03-05 10:17:17 UTC
Description of problem:

event_subscriber upgrade script fails on
any user that has an event_subscriber record.

Version-Release number of selected component (if applicable):
on upgrade from 3.3 to 3.4

How reproducible:
100%

Steps to Reproduce:
1. on engine 3.3 subscribe to an event from the engine.
2. upgrade to 3.4 (including running engine-setup)


Actual results:
on upgrade (engine-setup) you get:

psql:/home/alitke/ovirt-** FILTERED**/share/ovirt-**
FILTERED**/dbscripts/upgrade/ 03_05_0050_event_notification_
methods.sql:10:
ERROR: column "notification_method" contains null values
FATAL: Cannot execute sql command:
--file=/home/alitke/ovirt-** FILTERED**/share/ovirt-**
FILTERED**/dbscripts/upgrade/ 03_05_0050_event_notification_ methods.sql

2014-03-03 17:20:34 DEBUG otopi.context context._executeMethod:152 method
exception
Traceback (most recent call last):
File "/usr/lib/python2.7/site- packages/otopi/context.py", line 142, in
_executeMethod
method['method']()
File
"/home/alitke/ovirt-** FILTERED**/share/ovirt-** FILTERED**/setup/bin/../
plugins/ovirt-**FILTERED**- setup/ovirt-**FILTERED**/db/ schema.py",
line 280, in _misc
osetupcons.DBEnv.PGPASS_FILE
File "/usr/lib/python2.7/site- packages/otopi/plugin.py", line 451, in
execute
command=args[0],
RuntimeError: Command
'/home/alitke/ovirt-** FILTERED**/share/ovirt-**
FILTERED**/dbscripts/schema.
sh'
failed to execute

Expected results:
to error during upgrade

Additional info:
caused by creating a primary key on event_subscriber while newly created event_subscriber is null.

Comment 1 Mooli Tayer 2014-03-05 10:38:00 UTC

*** This bug has been marked as a duplicate of bug 1072549 ***


Note You need to log in before you can comment on or make changes to this bug.