Bug 1072704 - Cannot view VM console or VM details: 'NoneType' object has no attribute 'cpus'
Summary: Cannot view VM console or VM details: 'NoneType' object has no attribute 'cpus'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1075044 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-05 04:29 UTC by Major Hayden 🤠
Modified: 2014-03-11 12:13 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.0.0-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-11 03:58:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Major Hayden 🤠 2014-03-05 04:29:22 UTC
Description of problem:

After upgrading to virt-manager/virt-manager-common 1.0.0-3.fc20, I can't view the VM console or VM details in virt-manager.  I receive the following error on the screen:

  Error launching details: 'NoneType' object has no attribute 'cpus'

Version-Release number of selected component (if applicable):

Working version: 0.10.0-5.git1ffcc0cc.fc20
Non-working version: 1.0.0-3.fc20

How reproducible:

I build Xen HVM VM's in virt-manager 0.10.0-5 and was able to view/edit details and view the VM console without issues.  After upgrading to virt-manager 1.0.0-3, I could no longer view/edit details or view the VM console.  I was given the "Error launching details: 'NoneType' object has no attribute 'cpus'" error in virt-manager.

Steps to Reproduce:
1. Build a Xen VM in virt-manager 1.0.0-3
2. When the installation begins, you'll see the previously mentioned error
3. The VM will boot successfully but you can't view console/details in virt-manager

Actual results:

Error -> 'NoneType' object has no attribute 'cpus'

Expected results:

I'd expect to see the standard virt-manager window containing the VM console and details.

Additional info:

This affects PV and HVM Xen VM's from what I've seen.  Downgrading to virt-manager 0.10.0-5 fixes all the problems.  Restarting libvirtd had no effect.

Comment 1 Major Hayden 🤠 2014-03-05 04:30:36 UTC
Full traceback from virt-manager --debug:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 803, in _show_vm_helper
    details = self._get_details_dialog(uri, uuid)
  File "/usr/share/virt-manager/virtManager/engine.py", line 760, in _get_details_dialog
    obj = vmmDetails(con.get_vm(uuid))
  File "/usr/share/virt-manager/virtManager/details.py", line 530, in __init__
    self.init_details()
  File "/usr/share/virt-manager/virtManager/details.py", line 990, in init_details
    for name in [c.model for c in cpu_values.cpus]:
AttributeError: 'NoneType' object has no attribute 'cpus'
[Tue, 04 Mar 2014 22:13:31 virt-manager 21019] DEBUG (error:84) error dialog message:
summary=Error launching details: 'NoneType' object has no attribute 'cpus'
details=Error launching details: 'NoneType' object has no attribute 'cpus'

Comment 2 Cole Robinson 2014-03-06 16:33:53 UTC
Fixed upstream now

commit b078ba8c3d69b62fe748d9182babef8971914277
Author: Cole Robinson <crobinso@redhat.com>
Date:   Thu Mar 6 11:31:09 2014 -0500

    details: Fix fallback if fetching CPU models fails (bz 1072704)

Comment 3 Major Hayden 🤠 2014-03-06 16:50:07 UTC
Just made the edits from Cole's commit on my server and that fixed the bug.  I'm able to view VM consoles and details without issue.

Comment 4 Fedora Update System 2014-03-06 18:23:59 UTC
virt-manager-1.0.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.0-4.fc20

Comment 5 Fedora Update System 2014-03-07 15:04:40 UTC
virt-manager-1.0.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.0-5.fc20

Comment 6 Fedora Update System 2014-03-08 03:30:52 UTC
Package virt-manager-1.0.0-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.0.0-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3581/virt-manager-1.0.0-5.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-03-11 03:58:36 UTC
virt-manager-1.0.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Cole Robinson 2014-03-11 12:13:42 UTC
*** Bug 1075044 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.