Bug 1075044 - Virt-manager is not able to handle machines on rhel5 with xen.
Summary: Virt-manager is not able to handle machines on rhel5 with xen.
Keywords:
Status: CLOSED DUPLICATE of bug 1072704
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-11 11:57 UTC by Robin Hack
Modified: 2014-03-11 12:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-11 12:13:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Robin Hack 2014-03-11 11:57:59 UTC
Description of problem:
I just trying to get info of my virtual machines with virtual machine manager.


Version-Release number of selected component (if applicable):
virt-manager-1.0.0-3.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. have machine with rhel5 and xen installed. 
2. have windows machines on server
3. start virt manager from your local desktop (fedora 20) and double click to machine.


Actual results:
pop-up window raise:
Error launching details: 'NoneType' object has no attribute 'cpus'
Details:
Error launching details: 'NoneType' object has no attribute 'cpus'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 803, in _show_vm_helper
    details = self._get_details_dialog(uri, uuid)
  File "/usr/share/virt-manager/virtManager/engine.py", line 760, in _get_details_dialog
    obj = vmmDetails(con.get_vm(uuid))
  File "/usr/share/virt-manager/virtManager/details.py", line 530, in __init__
    self.init_details()
  File "/usr/share/virt-manager/virtManager/details.py", line 990, in init_details
    for name in [c.model for c in cpu_values.cpus]:
AttributeError: 'NoneType' object has no attribute 'cpus'

Expected results:
Have working virt-manager like before.

Additional info:

Comment 1 Cole Robinson 2014-03-11 12:13:42 UTC

*** This bug has been marked as a duplicate of bug 1072704 ***


Note You need to log in before you can comment on or make changes to this bug.