Bug 107294 - clearpart documentation misleading
clearpart documentation misleading
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: EasyFix
Depends On:
Blocks: 123819
  Show dependency treegraph
 
Reported: 2003-10-16 12:32 EDT by Rik Faith
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 15:07:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik Faith 2003-10-16 12:32:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The clearpart documentation in
file:///usr/share/doc/anaconda-9.0.93/kickstart-docs.html is misleading.  It states:

    For example, the following clears the partitions on the first two 
    drives on the primary IDE controller:

    clearpart --drives hda,hdb

This may have been true at one time, but now the default is CLEARPART_TYPE_NONE,
so this will do nothing.  I suggest you change this example to:

    clearpart --drives=hda,hdb --all

or

    clearpart --drives=hda,hdb --linux

(Note the = which makes the example consistent with the syntax used in the
earlier part of the documentation.)

Version-Release number of selected component (if applicable):
anaconda-9.0.93-1

How reproducible:
Always

Steps to Reproduce:
Kickstart on already partitioned drive with clearpart --drives=hda


Actual Results:  Error message (reproduced here:
http://www.bohnsack.com/lists/archives/xcat-user/1457.html), because anaconda
can't add more partitions, since none were removed.

At this point, an fdisk -l will also show all the old paritions.

This is not expected behavior based on the example in the documentation.

Expected Results:  Cleared partitions and successful kickstart.

Additional info:

Success is obtained with clearpart --drives=hda --all
Comment 1 Tammy Fox 2004-02-27 01:10:43 EST
This comes from the kickstart docs in the SAG. The SAG doc needs to be
fixed and then redumped to kickstart-docs.html and kickstart-docs.txt
for the anaconda package. Reassigning to new owner.
Comment 2 Andrius Benokraitis 2005-02-02 16:17:12 EST
Sounds good... this will be updated in the SAG for the next release,
which will be RHEL4. Unless the developer for anaconda disagrees! :-)

Reassigning to developer who owns ananconda to update the man page.
Comment 10 Andrius Benokraitis 2005-02-03 15:07:51 EST
Bug suggestion reviewed and approved for addition into the RHEL4-SAG.
Propogation to the /usr/share/doc/anaconda-*/kickstart-docs.html file
may come later, during a future RHEL4 Update.

Thanks for submitting the bug! :-)

Andrius.

Note You need to log in before you can comment on or make changes to this bug.