Bug 123819 - RHEL4-0day: System Admin Guide tracker bug
RHEL4-0day: System Admin Guide tracker bug
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhel-sag (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrius Benokraitis
John Ha
: FutureFeature
Depends On: 83834 92223 102541 106003 106846 107294 108709 111876 112044 112609 113004 113458 114235 114236 114483 115324 123717 123824 125521 125895 126934 127055 128386 133148 139795 145457
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 14:38 EDT by Karsten Wade
Modified: 2015-07-14 00:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 15:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2004-05-20 14:38:08 EDT
This bug serves two capacities:

1. One location to write down all of the changes that we notice need
to be done in the SAG.  This will help another writer pick-up where
previous writers leave off.  In the event that we divide the book and
each tackle a set of chapters, this bug is a central tracker for that
work.

2. One bug top be blocked by every bug, RFE, etc. in bugzilla for the SAG.
Comment 1 Karsten Wade 2004-05-20 14:42:54 EDT
Across the entire guide, we need to substitute 'system-config-*' for
'redhat-config-*'.
Comment 2 Karsten Wade 2004-05-20 15:15:53 EDT
Adding all of the other bugs as dependencies will help this bug track
the various bug reports against the SAG.  Unfortunately, changes to
this ticket 123819 will spam each of the people on the dependency list
for every change, and this is obviously unacceptable.

This bug is now just a master tracker, and Red Hat writers will use
123824 for tracking individual modifications during development work
on the SAG for RHEL 4.  Note that 123824 is a closed-viewing bug, and
this bug (123819) has been opened to view.

Sorry about the spam!  It should stop now. :)
Comment 3 Andrius Benokraitis 2004-11-23 13:42:02 EST
 http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/s1-kernel-perform-upgrade.html

 1> install using -i
<JuanDRay> 2> reboot
<JuanDRay> 3> uninstall old kernel
<JuanDRay> or you can skip the reboot...
<JuanDRay> I guess.
<JuanDRay> but this procedure shoutl be used by anything that provides
modules for a specific kernel as well...
<JuanDRay> s/should/shoutl
<JuanDRay> I will look at GFS real quick to see if it falls in this
category...
<JuanDRay> there are a couple of reasons:
<JuanDRay> 1> using -F/-U on kernels can leave your system unbootable
if the installation fails (especially when third party modules are not
present in the new module tree and an intird cannot then be created)
<JuanDRay> 2>  using -F/-U on kernels leaves the system in a voletile
state if not rebooted immediately as the module tree is removed for
the running kernel and modules are loaded dynamically
<JuanDRay> 3> grubby needs to have a sample stanza in the grub.conf or
lilo.conf. If only one kernel is present, -U/-F can cause the
rewriting of those files to fail during the postinstallation process
of the package (leaving the system unbootable)
<JuanDRay> 4> Changes in the way -U/-F works in the rpm that ships
with RHEL 3 and beyond, will cause the command: rpm -U kernel to
remove *all* other packages that provide kernels (i.e. kernel-smp and
kernel-hugemem on x86)
<JuanDRay> This is because RPM now looks not just at the name of the
package, but also what it provides...
<JuanDRay> so you can rpm -U kernel-smp, and it will update kernel-smp
<JuanDRay> (as it is named kernel-smp, so this is what is determined
to be what primarily provides)
<JuanDRay> but kernel-smp provides kernel and kernel-smp, so if you
have both kernel and kernel-smp installed, rpm -U kernel will remove
*both* kernel and kernel-smp packages and install the *new* kernel.
Comment 4 Andrius Benokraitis 2005-04-28 15:18:24 EDT
Boo yeah!

All future submitted bugs for the SAG are to be assigned to each individual
Update blocker bug.

Note You need to log in before you can comment on or make changes to this bug.