Bug 107304 - Installer crashes after boot loader upgrade splash screen and searching packages to upgrade
Installer crashes after boot loader upgrade splash screen and searching packa...
Status: CLOSED DUPLICATE of bug 106965
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
RC3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 14:06 EDT by Benjamin Baez
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Baez 2003-10-16 14:06:06 EDT
Description of problem:

Dell Latitude C810 RC2 to RC3 upgrade

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

{more}...


Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Enter at boot: prompt
2. 2-button mouse PS/2
3. Upgrade installation
4. Upgrade boot loader
    
Actual results:
Unexpected Exception

Expected results:
Upgrade packages

Additional info:
I couldn't enter the bug in your new bugzilla,
http://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi

got document contains no data

Couldn't post whole dump since > 65,535 chars
Comment 1 Jeremy Katz 2003-10-16 14:07:37 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.