Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1073076 - [GSS] (6.3.0) HHH-3482: UnsupportedOperationException with StatelessSession
[GSS] (6.3.0) HHH-3482: UnsupportedOperationException with StatelessSession
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: DR2
: EAP 6.3.0
Assigned To: Brett Meyer
Zbyněk Roubalík
Russell Dickenson
:
Depends On:
Blocks: 1063408 1073118 1087625
  Show dependency treegraph
 
Reported: 2014-03-05 12:34 EST by Brett Meyer
Modified: 2015-09-01 00:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Instances of `UnsupportedOperationError` being thrown when using StatelessSession and saving a ManyToOne have been addressed in this release of JBoss EAP 6. The error was caused by a call to `getTimestamp()` method which was not implemented for StatelessSession. The `UnsupportedOperationError` no longer presents.
Story Points: ---
Clone Of: 1073018
: 1073118 (view as bug list)
Environment:
Last Closed: 2014-06-28 11:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Meyer 2014-03-05 12:34:03 EST
+++ This bug was initially created as a clone of Bug #1073018 +++

How reproducible:
Consistently

Steps to Reproduce:
1. Enable 2nd level caching
2. Run the original HHH-3482 testcode against Hibernate 4.2.7.SP1

Actual results:
java.lang.UnsupportedOperationException
Comment 1 Kabir Khan 2014-04-04 11:27:54 EDT
Fixed by upgrade -> ON_QA
Comment 2 Jan Martiska 2014-04-15 09:08:53 EDT
Verified in EAP 6.3.0.ER1.

Note You need to log in before you can comment on or make changes to this bug.