Bug 10733 - Problem with pcmcia initialization on laptops
Summary: Problem with pcmcia initialization on laptops
Status: CLOSED DUPLICATE of bug 10496
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.2
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-11 21:19 UTC by Ram Bandreddi
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-12 16:28:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ram Bandreddi 2000-04-11 21:19:28 UTC
I just installed Red Hat 6.2 on my Thinkpad 600E.  Everything works fine
now but I had a few minor issues getting the network card to work.  Even
though my NIC is supported, I noticed that the network interface was never
initialized because the network initialization script (S10network) happens
before the pcmcia card(s) are recognized (S45pcmcia).  Naturally a pcmcia
network card cannot be initialized if it doesn't 'exist' yet.  I could get
around this by running '/etc/sysconfig/network-scripts/ifup eth0' but I
didn't want to do that every time I booted the machine. I fixed this
problem by changing all 'S45pcmcia' entries in /etc/rc.d/rc?.d
to 'S05pcmcia' to force pcmcia initialization to happen before the network
initialization script.  Is there some reason why pcmcia initialization is
done in that order?  If not, I would suggest giving it a much lower
number, ie. less than 10.

--Aaron Ogden

Comment 1 Bill Nottingham 2000-04-12 15:39:59 UTC
The network interface should be initialized when pcmcia starts -
you're saying it does not happen then?

Comment 2 Bill Nottingham 2000-04-12 16:28:59 UTC
*** This bug has been marked as a duplicate of 10496 ***


Note You need to log in before you can comment on or make changes to this bug.