This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1073457 - Auto-completion issue with sudo dnf install
Auto-completion issue with sudo dnf install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Elad Alfassa
Fedora Extras Quality Assurance
:
: 1082254 (view as bug list)
Depends On:
Blocks: 871892
  Show dependency treegraph
 
Reported: 2014-03-06 08:24 EST by Steven Franzen
Modified: 2015-07-21 04:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:57:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Auto-completion with yum and dnf (274 bytes, text/plain)
2014-03-06 08:24 EST, Steven Franzen
no flags Details
Auto-completion results (134 bytes, text/plain)
2014-03-06 09:52 EST, Steven Franzen
no flags Details

  None (edit)
Description Steven Franzen 2014-03-06 08:24:03 EST
Created attachment 871446 [details]
Auto-completion with yum and dnf

Description of problem:
When trying to install a package with e.g. "sudo dnf install lib", performing tab completion results in dnf immediately asking for the root (or user) password, as shown in the attachment. After authenticating, completion is no longer possible and dnf starts trying to install whatever name fragment was entered.

Version-Release number of selected component (if applicable):
0.4.16-2

How reproducible:
At any time the user has to authenticate for sudo.

Steps to Reproduce:
1. Invoke tab completion on a "sudo dnf install" command.

Actual results:
dnf requests authentication and breaks off the completion.

Expected results:
Require root access only for actually installing, not for listing package database contents, like yum.

Additional info:
The same operation performed with yum is also included in the attachment.
Comment 1 Ales Kozumplik 2014-03-06 08:39:36 EST
Elad can you please take a look and decide how to handle this?
Comment 2 Steven Franzen 2014-03-06 09:52:37 EST
Created attachment 871500 [details]
Auto-completion results

After reading through some more reports against dnf, I can confirm that this issue does not occur with dnf-plugins-core (0.0.5-2) also installed; in this case the completion matching is performed very quickly. However, yum and dnf report different numbers of possible matches (see attachment).
Comment 3 Ales Kozumplik 2014-03-31 02:35:55 EDT
*** Bug 1082254 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2014-05-28 08:08:43 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 5 Fedora Update System 2014-05-28 19:48:34 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-05-31 19:57:07 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 limkokhole@gmail.com 2015-07-21 04:14:49 EDT
The problem still exist if i set it as alias, i.e. `alias dnf="sudo dnf" on ~/.bashrc.

Note You need to log in before you can comment on or make changes to this bug.