Bug 1073511 - [RFE] manage provisioning templates by changesets
Summary: [RFE] manage provisioning templates by changesets
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1268725 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-06 15:00 UTC by Nick Strugnell
Modified: 2017-04-25 16:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-09 15:43:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1122823 None None None Never

Internal Links: 1122823

Description Nick Strugnell 2014-03-06 15:00:11 UTC
Description of problem:

I'm currently designing a continuous integration environment for Red Hat builds. We identify a build as consisting of:
1. Kickstart file+snippets
2. Puppet classes

The CI environment always builds test machines against the Library. Releases are managed by creating content views and promoting them to higher (more stable) environments using changesets.

The problem here is that kickstart files and snippets are globally visible. We cannot therefore version them and manage them through the environments, other than by naming conventions - this then requires renaming, and careful changing of associated environment/host-groups when promoting. This is particularly complicated with snippets, which must be renamed, and then the master kickstart edited to ensure it refers to the correct snippets.

It would be extremely useful for provisioning templates to have environment scope and to be promoted via changesets, exactly as we do for puppet modules and packages.

Comment 1 RHEL Product and Program Management 2014-03-06 15:27:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Bryan Kearney 2015-11-05 16:19:25 UTC
*** Bug 1268725 has been marked as a duplicate of this bug. ***

Comment 8 Tomas Strachota 2016-11-09 15:43:27 UTC
Closing this bug out since we do not believe it will be fixed in the next multiple releases due to the priority of this bug as compared to others. If this is a large impact on you, please feel free to re-open it and provide additional information to help us better prioritize it.

Alternatively to the required functionality, you can currently use foreman-templates plugin, that allows synchronization of templates from external git repository.


Note You need to log in before you can comment on or make changes to this bug.