Bug 107377 - installer crashes when looking for packages
installer crashes when looking for packages
Status: CLOSED DUPLICATE of bug 106965
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-17 12:01 EDT by Jason
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2003-10-17 12:01:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am trying to install fedora core test3.  I have to use linux nofb text to 
install because my monitor is not detected.  There is another ticket open 
already to have my monitor added to the database.  I answer the mouse question, 
language, choose to update existing fedora core test2 system and then the 
installer crashes.  Attached the file the crash generated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  use linux nofb text
2.  answer the questions until upgrade existing system
3.  installer crashes
    

Actual Results:  system tells me a crash has happened and to send this file to 
you

Expected Results:  I should be able to install test3

Additional info:
Comment 1 Jason 2003-10-17 12:06:02 EDT
I can't upload the crash text at the moment.  I keep getting page not found 
when I try to submit an upload.  Here is the first several lines from the 
text.  Maybe it will be a start.  I will try to upload the file later today.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1120, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 474, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <text.InstallInterface instance at 0x98665cc>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' 
from '/usr/lib/anaconda/findpackageset.py'>
instPath: /mnt/sysimage
package: <rpm.hdr object at 0x97cba80>
h: <rpm.hdr object at 0xa5ced70>
mi: <rpm.mi object at 0xa5c8408>
ts: <rpm.ts object at 0xbb51830>
method: <image.CdromInstallMethod instance at 0x9db20e4>
myarch: i386
currentVersion: 0.94
hasX: 1
file: __db.003
supportedUpgradeVersion: -1
release: 0.20030924
found: 0
Comment 2 Jeremy Katz 2003-10-17 13:05:11 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.