Bug 107407 - httpd crashes when using gd from php
httpd crashes when using gd from php
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-17 15:46 EDT by Oskari Saarenmaa
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-01 06:10:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oskari Saarenmaa 2003-10-17 15:46:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
The current rawhide version of PHP (inside Apache) crashes randomly when GD
functions are used.  Apparently this happens because Rawhide's PHP is linked
against external GD library that is not thread safe and it causes random memory
corruption.  Using the gd library that is bundled with PHP fixes the problem.

Version-Release number of selected component (if applicable):
php-4.3.3-4

How reproducible:
Always

Steps to Reproduce:
1. Install gd, httpd, and php
2. Make a simple script using gd
3. Load a few pages and see it crash
    

Additional info:
Comment 1 Joe Orton 2003-10-22 04:14:51 EDT
Should be fixed in php-4.3.3-6.
Comment 2 Joe Orton 2003-12-01 06:10:36 EST
Thanks a lot for tracking that down: do you have more information on
why it crashes?
Comment 3 Oskari Saarenmaa 2003-12-02 08:32:46 EST
I haven't had time to check what exactly is wrong with the GD in
Rawhide and Fedora, but I have verified that the problem is fixed by
php-4.3.3-6 and php-4.3.4-1.1

Note You need to log in before you can comment on or make changes to this bug.