Bug 107480 - Anaconda crashes with unhandled Python exception after installing pkgs
Anaconda crashes with unhandled Python exception after installing pkgs
Status: CLOSED DUPLICATE of bug 106965
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-18 21:25 EDT by Robert Myers
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump produced by anaconda and saved to floppy as requested. (611.89 KB, text/plain)
2003-10-18 21:28 EDT, Robert Myers
no flags Details

  None (edit)
Description Robert Myers 2003-10-18 21:25:55 EDT
Description of problem:

Upgrading from Severn Test 2 to Severn Test 3, Anaconda produces an unhandled
exception after installing most packages.


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Go through Anaconda installation process, request upgrade
2.
3.
    
Actual results:

Unhandled exception after most packages installed.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int


Expected results:

Completed upgrade.

Additional info:

My system is bootable and usable, presumably with a mixture of Test2 and Test3
Severn packages.
Comment 1 Robert Myers 2003-10-18 21:28:07 EDT
Created attachment 95291 [details]
dump produced by anaconda and saved to floppy as requested.
Comment 2 Jeremy Katz 2003-10-18 23:11:52 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.