Bug 107559 - RFE: Pre-filled values on network install
RFE: Pre-filled values on network install
Status: CLOSED DUPLICATE of bug 35236
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 12:50 EDT by Sean Earp
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Earp 2003-10-20 12:50:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.22; Mac_PowerPC)

Description of problem:
When doing a network install of Fedora, you are prompted to fill in the FTP 
server and directory for the source files.  This makes sense, and you should 
still have the ability to do this, but it would be nice if there were one or 
two generic install locations available to select with a checkbox or drop down 
box for those of us who just want to install from the generic RH servers (or a 
few suitable mirrors).  Generally the URL to the source files is quite long, 
when downloading from a mirror, ie:

Server: ftp.dulug.duke.edu
Path: ftp.redhat.com/pub/redhat/linux/beta/severn/en/os/i386/

For a newbie, it can be daunting to find a server that hosts the i386 
directory, and then type in a huge URL, without making a mistake somewhere 
along the way and giving up.  I think of it kind of like Anaconda's option for 
selecting a NTP server.  You can manually type in any server you want, but for 
those of us not wanting to go look up a suitable NTP server, we can just select 
clock.redhat.com from a list, and be off to the races.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose FTP (or other network) install
2.
3.
    

Actual Results:  Have to find an FTP server URL on ANOTHER computer, since the 
computer running anaconda is in the process of loading the OS

Expected Results:  Have a drop down box to choose a pre-configured FTP install 
location

Additional info:
Comment 1 Jeremy Katz 2003-10-20 14:08:48 EDT
To do this nicely really requires a sane mirror list (see my post to
fedora-devel-list I think from over the weekend).  Mirrors are all organized
differently, so you can't just assume any one layout :/
Comment 2 Sean Earp 2003-10-20 14:30:44 EDT
You are CERTAINLY correct on the layout of the mirrors, but worst case scenario, you could just 
use RH server information, which is fairly consistent (same as you do with the NTP server 
information in anaconda).
Comment 3 manuel wolfshant 2003-12-31 16:24:02 EST
At least from my country, access to RH servers is much (much as in a
few orders of magnitude) slower then to local metropolitan mirrors.
With a fiber optic metropolitan connection, but only 64/128 kbps
international access you will definitely prefer manually typing the
path to the local mirror rather then wait for ages. In my case, I
already know by heart 3 major local mirrors and just randomly switch
among them when I need to download. The difference is 6 MB/sec (local
mirrors) versus 3 kb/sec (RH servers).
Not to mention that, since I have a lot of systems to take care of, I
have a local (local as 'placed in my company') mirror of the
distributions I currently use, which is rsync-ed with an official
mirror, and periodically has the updates included in the installation
tree, so as to avoid applying them after each new install.
Comment 4 Jeremy Katz 2004-09-22 14:39:57 EDT

*** This bug has been marked as a duplicate of 35236 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:59:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.