Bug 35236 - RFE: Anaconda should display a list of mirrors for FTP/HTTP installs
RFE: Anaconda should display a list of mirrors for FTP/HTTP installs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature
: 107559 174073 205644 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2001-04-08 14:16 EDT by Jim Phillips
Modified: 2014-01-21 17:48 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Phillips 2001-04-08 14:16:26 EDT
As sexy and useful as the anaconda installer is, it lacks the one feature
that could make the network installation process even easier.  *nix
installations such as OpenBSD present network installers with a list of
mirrors to use during FTP/HTTP installs.  Anaconda should do the same.  It
couldn't be that difficult.. Just another file maintained in a pernanent
known location with a list of all the anonymous mirror sites and the
directory that the redhat installation is in.
Comment 1 Brent Fox 2001-04-09 16:29:25 EDT
Marking as RFE (Request for enhancement).  I'll put this on our list of possible
enhancements for future releases.  Also marking as deferred.  Thanks for your
report.
Comment 2 Michael Fulbright 2001-04-11 16:24:21 EDT
This is not something we plan on adding to the installer.
Comment 3 Aleksey Nogin 2004-02-17 21:59:42 EST
IMHO this "WONTFIX" should be reevaluated for Fedora. Fedora is
supposed to be more open, so (IMHO again), showing a standard list of
mirrors in the installer seems appropriate in Fedora.
Comment 4 Barry K. Nathan 2004-05-28 05:55:29 EDT
If a mirror list is added to the FC3 installer, *please* make sure
other FTP/HTTP servers can still be easily specified. In my case, any
HTTP installs will be off a private install server, to avoid going out
over the Internet with each install...
Comment 5 Warren Togami 2004-06-14 21:21:55 EDT
FC3 target
This would force us to do a better job of maintaining the "official"
mirror list too.
Comment 6 Jeremy Katz 2004-09-22 14:40:05 EDT
*** Bug 107559 has been marked as a duplicate of this bug. ***
Comment 7 Sean Earp 2005-04-26 22:45:14 EDT
You know, yum manages to work with a mirror list for updating massive quantities
of RPM's at a time (especially with Rawhide on the current FC tests)... It
actually works quite well.  Maybe if some ideas are needed for the
implementation, Seth Vidal might be the man to talk to...

-Sean
Comment 8 Rahul Sundaram 2005-08-13 22:34:46 EDT
ping
Comment 9 yendis0001 2006-01-20 18:47:58 EST
Anaconda fails when trying to download off of a http site. Between the domain 
name and file directory, it replicates the / so the file cannot be found.  
when i enter this 
download.fedora.redhat.com 
pub/fedora/linux/... 
it puts in http://download.fedora.redhat.com//pub/fedora/.. 
This is on Fedora Core 4 and 1 
 
Another bug is that "linux ide=nodma" has to be typed for it to install 
correctly, otherwise it won't work on some computers. 
Comment 11 Jacek Pliszka 2006-04-23 18:51:29 EDT
If possible - in the mirror list I would like to be able to pick protocols.
My intranet is heavily firewalled and ftp does not work.

Another idea is picking the miror list through timezone/country.

I am from Poland so the best first shot for mirrors for me would be those
located in Poland.
Comment 12 Chris Lumens 2006-09-07 16:01:44 EDT
*** Bug 205644 has been marked as a duplicate of this bug. ***
Comment 13 Rahul Sundaram 2006-09-25 11:18:05 EDT
*** Bug 174073 has been marked as a duplicate of this bug. ***
Comment 14 Matthias Saou 2006-09-29 05:30:19 EDT
Now that there is the server-side GeoIP code on the Fedora download servers,
maybe anaconda could be pointed at that in order to retreive a list of close and
available mirror servers for the selected protocol?
Comment 15 Susi Lehtola 2006-11-10 06:40:50 EST
By the way, now that the installer support additional repositories would it be a
big task to put in the updates-repository also, so that when you install you
automatically get the newest versions of packages and you won't necessarily have
to update right after the installation?

Now I am using Novi to update the install tree once a week.
Comment 16 Chris Lumens 2006-11-10 09:47:13 EST
No, that would be trivial to do.  However adding the updates repo received
exactly no testing before FC6, so we decided to hold off on enabling that by
default until the next release.  If you test this out somewhat regularly and it
works for you, please let us know closer to the first test release of FC7 so we
remember to enable it.  Thanks.
Comment 17 Susi Lehtola 2006-11-29 11:40:02 EST
I've tested the installation with the updates repo added a couple of times and
the outcome is not what it should be. Anaconda doesn't install the newest
packages, which can be seen by running yum update after the install - hundreds
of packages are updated.

There is still some work to be done.
Comment 18 Valent Turkovic 2008-01-24 08:57:13 EST
Please add list of mirror urls in anaconda as a drop down menue, but also leave
the option to type it by hand.

I just did my first rawhide install and did it over the network.
I managed to get it installed after 3rd try! First time in the middle of install
(466 of 906 packages) kuduz got updated under my feet, and anaconda needed the
old version to install - and only option is to reboot :(
Second try froze for some unknown reason in the middle of anaconda launch.
Third time I started the install from my home and realised that the piece of
paper on which I wrote ftp url of rawhide I left at work :(
Comment 19 Valent Turkovic 2008-01-24 09:01:20 EST
Now I see that this RFE is from 2001!?!
Is this a such a hard thing to add to anaconda?
Comment 20 Jeremy Katz 2008-04-08 15:01:14 EDT
We actually have all of the infrastructure now so that we can knock this one out
for Fedora 10.  We didn't land the infrastructure in time to get all of the
necessary string and UI changes into Fedora 9
Comment 21 Chris Lumens 2008-07-15 17:11:17 EDT
Well, we are now automatically using the Fedora mirrorlist in rawhide.  If you
boot with the boot.iso and don't specify a URL via the command line (as in, the
way most people install) then you will by default get the mirrorlist.  Our
mirror site attempts to sort the list such that the ones closest/fastest to you
are at the top of the list.  So we are effectively doing this without requiring
anything of the user at all.

Comments about enabling the updates repo really don't belong on this bug. 
They're totally separate.
Comment 22 CAI Qian 2008-07-19 11:53:26 EDT
How about users who booting vmlinuz and initrd.img from isolinux directory in
Rawhide tree? There was no mirrorlist when to install via URL, so they still
need to remember and specify a URL manually.
Comment 23 Jesse Keating 2008-10-03 18:46:40 EDT
that's not quite right.  You have to input a url to get stage2 from, which really, if you're not booting with stage2, you likely have a local mirror of it and want to use that anyway.  I'm closing this given Chris' comment #21

Note You need to log in before you can comment on or make changes to this bug.