Bug 10756 - undefined symbol: fdio
Summary: undefined symbol: fdio
Status: CLOSED DUPLICATE of bug 33916
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmfind (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-12 16:05 UTC by david.heim
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 14:08:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description david.heim 2000-04-12 16:05:39 UTC
I installed rpmfind from Redhat 6.2 on a partially updated RedHat 6.0
system.  All the dependencies were satisfied. When I tried to run it I got
	rpmfind: error in loading shared libraries: rpmfind: undefined
	symbol: fdio

Comment 1 Jeff Johnson 2000-04-12 16:20:59 UTC
Upgrade to rpm-3.0.4 from 6.2 as well.

Comment 2 Anonymous 2000-04-12 17:17:59 UTC
Okay thanks.

The fact that the dependencies for rpmfind don't "require" RPM 3.0.4 while
rpmfind does, strikes me as a (minor) bug.

Comment 3 Greg Lopp 2000-09-10 05:05:50 UTC
Experincing a similar problem with the combination of rpmfind-1.4-3 and
rpm-4.0-0.67.6x.  Whenever I try to run it, I get :
rpmfind: error in loading shared libraries: /usr/lib/librpm.so.0: undefined
symbol: ufdio

Hardly worth reporting, except for two differences :
1) Different symbol (or at least a different spelling)
2) Previous problem supposedly resolved by upgrading rpm package.  My problem
exists with the latest(?) version.

Comment 4 Jeff Johnson 2001-04-03 14:08:18 UTC

*** This bug has been marked as a duplicate of 33916 ***

Comment 5 Daniel Veillard 2001-07-17 23:18:18 UTC
Had been fixed in all recent releases,

Daniel


Note You need to log in before you can comment on or make changes to this bug.