Bug 33916 - rpmfind broken after upgrade to rpm 4.0.2
Summary: rpmfind broken after upgrade to rpm 4.0.2
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmfind   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 10756 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 19:39 UTC by David E. Young
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-30 16:37:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David E. Young 2001-03-29 19:39:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.14-5.0 i586)


After upgrading to rpm 4.0.2, rpmfind fails with the following:

  rpmfind: error in loading shared libraries: /usr/lib/librpm.so.0:
undefined symbol: ufdio


Reproducible: Always
Steps to Reproduce:
1. upgrade to rpm 4.0.2
2. run 'rpmfind'
3.
	

Actual Results:  rpmfind: error in loading shared libraries:
/usr/lib/librpm.so.0: undefined symbol: ufdio


Expected Results:  Actually, this error causes the Ximian Gnome update
agent to fail.

Comment 1 Jeff Johnson 2001-04-03 14:08:13 UTC
*** Bug 10756 has been marked as a duplicate of this bug. ***

Comment 2 Jan Carlson 2001-04-03 15:18:13 UTC
rpm-4.0.2 not only breaks rpmfind, it also breaks
rebuilding of the rpmfind rpm!

I need a workaround, please!  My boss wants rpmfind
to work again, and I can't reinstall his machine just
to get rid of rpm-4.0.2. 

Help me fix rpmfind so my boss will stop saying that
Red Hat updates are evil!

Comment 3 Daniel Veillard 2001-05-14 15:17:22 UTC
This is an rpmfind FAQ:
http://rpmfind.net/linux/rpm2html/faq.html

Possible solution: grab the source RPM and rebuild it locally as explained
in entry #4

Daniel

Comment 4 Jeff Johnson 2001-06-30 16:37:37 UTC
This problem appears resolved, reopen if not.

Comment 5 Daniel Veillard 2001-07-17 23:19:51 UTC
Okay seems fixed, then let's close this bug,

Daniel


Note You need to log in before you can comment on or make changes to this bug.