Bug 107596 - (E100) invalid driver asignation
(E100) invalid driver asignation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
: 107597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 18:05 EDT by acount closed by user
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 16:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-10-20 18:05:43 EDT
Description of problem:

e100 driver doesn't support this devices:

0x1014  0x005c  "e100"  "IBM|i82557B 10/100"
0x10c3  0x1100  "e100"  "Samsung Semiconductors, Inc.|Smartether100 SC1100 LAN
Adapter (i82557B)"
0x1259  0x2560  "e100"  "Allied Telesyn International|AT-2560 Fast Ethernet
Adapter (i82557B)"
0x1266  0x0001  "e100"  "Microdyne Corporation|NE10/100 Adapter (i82557B)"
0x8086  0x1002  "e100"  "Intel Corp.|Pro 100 LAN+Modem 56 Cardbus II"
0x8086  0x1035  "e100"  "Intel Corp.|82801CAM (ICH3)/82562EH (LOM) Ethernet
Controller"
0x8086  0x1036  "e100"  "Intel Corp.|82801CAM (ICH3) 82562EH Ethernet Controller"
0x8086  0x1037  "e100"  "Intel Corp.|82801CAM (ICH3) Chipset Ethernet Controller"
0x8086  0x1227  "e100"  "Intel Corp.|82865 EtherExpress PRO/100A"
0x8086  0x1228  "e100"  "Intel Corp.|82556 EtherExpress PRO/100 Smart"
0x8086  0x5200  "e100"  "Intel Corp.|EtherExpress PRO/100 Intelligent Server"
0x8086  0x5201  "e100"  "Intel Corp.|EtherExpress PRO/100 Intelligent Server"
Comment 1 Bill Nottingham 2003-10-20 18:24:19 EDT
*** Bug 107597 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-10-20 18:36:11 EDT
The intel IDs at least are supported by eepro100; there's no reason that e100
can't support them, I'd think.
Comment 3 acount closed by user 2003-10-21 02:23:17 EDT
e100 _only_ gets support for:

0x8086, 0x1029
0x8086, 0x1030
0x8086, 0x1031
0x8086, 0x1032
0x8086, 0x1033
0x8086, 0x1034
0x8086, 0x1038
0x8086, 0x1039
0x8086, 0x103A
0x8086, 0x103B
0x8086, 0x103C
0x8086, 0x103D
0x8086, 0x103E
0x8086, 0x1050
0x8086, 0x1051
0x8086, 0x1052
0x8086, 0x1053
0x8086, 0x1054
0x8086, 0x1055
0x8086, 0x1059
0x8086, 0x1209
0x8086, 0x1229
0x8086, 0x2449
0x8086, 0x2459
0x8086, 0x245D
--

eepro100 , in theory, supports more NIC but _intel guys_ said that it's not
possible because they are special  hardware:
0x8086  0x1035
0x8086  0x1036
0x8086  0x1037
0x8086  0x1227
0x8086  0x1228
0x8086  0x5200
0x8086  0x5201

and these are strangers for eepro100 and e100 drivers:
0x1014  0x005c
0x10c3  0x1100
0x1259  0x2560
0x1266  0x0001
Comment 4 Jeff Garzik 2004-06-14 13:23:00 EDT
Bill?

Should this be assigned back to me, or is this for hwdata?
Comment 5 acount closed by user 2004-06-14 15:00:17 EDT
it's for hwdata guy(s).

And they need to get a lot of PCI ID's from _all_ net and scsi drivers
because hwdata asignations are very old.
Comment 6 Bill Nottingham 2004-06-28 16:25:01 EDT
Well, hopefully most new drivers just use their own device tables. In
theory, lots of the pcitable lines can just be removed.
Comment 7 Bill Nottingham 2004-06-28 16:27:52 EDT
e100 assignations removed in CVS.

Note You need to log in before you can comment on or make changes to this bug.