This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 107609 - balsa sigsegvs quite often
balsa sigsegvs quite often
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: balsa (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-21 02:48 EDT by Mario Mikocevic
Modified: 2006-08-07 21:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 21:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2003-10-21 02:48:08 EDT
Description of problem:
% gdb /usr/bin/balsa
(gdb) run --disable-crash-dialog
Starting program: /usr/bin/balsa --disable-crash-dialog
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 29042)]

(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
opening Inbox..
[New Thread 213006 (LWP 29058)]

(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...TODO: part_info_init_application
[New Thread 229391 (LWP 29071)]

(no debugging symbols found)...[New Thread 245776 (LWP 29072)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 29042)]
0x080c1cdc in libbalsa_message_body_save ()
(gdb) bt
#0  0x080c1cdc in libbalsa_message_body_save ()
#1  0x080781e8 in balsa_message_get_type ()
#2  0x08078443 in balsa_message_get_type ()
#3  0x40c26051 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#4  0x40c13cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#5  0x40c25bbf in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#6  0x40c24c36 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0

Version-Release number of selected component (if applicable):
# rpm -qv balsa
balsa-2.0.15-1

How reproducible:
Load _several_ procmailed mboxes and just read. Eventualy it barfs, it's quite
often.

Additional info:
# rpm -qv rawhide-release                        
rawhide-release-20031016-1
Comment 1 Mario Mikocevic 2003-10-21 03:06:58 EDT
One more ->

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 29118)]
0x4100ad5b in strlen () from /lib/i686/libc.so.6
(gdb) bt
#0  0x4100ad5b in strlen () from /lib/i686/libc.so.6
#1  0x40fdc3e5 in vfprintf () from /lib/i686/libc.so.6
#2  0x0812917e in RFC822Specials ()
#3  0x00000001 in ?? ()
#4  0x40f396bc in pthread_mutex_unlock () from /lib/i686/libpthread.so.0
Previous frame inner to this frame (corrupt stack?)
Comment 2 Mario Mikocevic 2003-10-23 05:03:01 EDT
One more, this one quite interesting ->

** ERROR **: file body.c: line 176 (libbalsa_message_body_type): should not be
reached
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread 16384 (LWP 7035)]
0x40fbdbe1 in kill () from /lib/i686/libc.so.6
(gdb) bt
#0  0x40fbdbe1 in kill () from /lib/i686/libc.so.6
#1  0x40f3c211 in pthread_kill () from /lib/i686/libpthread.so.0
#2  0x00000006 in ?? ()
#3  0x40f41c04 in __JCR_LIST__ () from /lib/i686/libpthread.so.0
#4  0x00000006 in ?? ()
#5  0x00000004 in ?? ()
#6  0xbfffeaa4 in ?? ()
#7  0x40f3c51b in raise () from /lib/i686/libpthread.so.0
Previous frame inner to this frame (corrupt stack?)
Comment 3 Mario Mikocevic 2003-10-23 05:20:38 EDT
Umh, one more on 'Reply' button ->

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 7333)]
0x080d54ed in process_mime_part ()
(gdb) bt
#0  0x080d54ed in process_mime_part ()
#1  0x080d56fb in process_mime_part ()
#2  0x080d54b9 in process_mime_part ()
#3  0x080d578b in content2reply ()
#4  0x080aea72 in add_attachment ()
#5  0x080af11c in add_attachment ()
#6  0x080b033a in sendmsg_window_new ()
#7  0x08070f66 in balsa_index_selected_list ()
#8  0x08070ff2 in balsa_message_reply ()
#9  0x40c27051 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#10 0x40c14cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#11 0x40c26bbf in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#12 0x40c25c36 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Comment 4 Carlos Morgado 2003-10-23 06:08:30 EDT
This is rather weird, the should not be reached message probably means the
internal structures are damaged. Also, at least 2 stack traces are munged.
What mail storage are you using ? Does this happen on particular messages or
seemingly at random ? Is balsa the only app misbehaving ? Are you using a RH
kernel ? 
Comment 5 Mario Mikocevic 2003-10-23 06:35:47 EDT
This is heavily procmailed mail storage meaning that in ~/Mail I have like
15 mboxes filled with fetchmail through procmail. In balsa all of them are
open on startup and I noticed that if I disable fetchmail I can browse
through all folders without any problem (no new mail though). The problem is
that it happens randomly, almost never on the same message. Currently yes,
balsa is the only one crashing.

This is daily updated rawhide (well, last two days it's r-x------ :) and
Linus's (or should I say Marcelo's) 2.4.23-pre7 kernel.
Comment 6 Mario Mikocevic 2003-10-30 03:56:50 EST
One more on 'Save selected' ->

(balsa:20584): Gdk-WARNING **: Error converting from UTF-8 to 'ISO-8859-2':
Invalid byte sequence in conversion input

(balsa:20584): Gdk-WARNING **: Error converting from UTF-8 to 'ISO-8859-2':
Invalid byte sequence in conversion input

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 20584)]
0x4100bd5b in strlen () from /lib/i686/libc.so.6
(gdb) bt
#0  0x4100bd5b in strlen () from /lib/i686/libc.so.6
#1  0x40fdd3e5 in vfprintf () from /lib/i686/libc.so.6
#2  0x0812917e in RFC822Specials ()
#3  0x00000001 in ?? ()
#4  0x40f3a6bc in pthread_mutex_unlock () from /lib/i686/libpthread.so.0
Previous frame inner to this frame (corrupt stack?)
Comment 7 Bill Nottingham 2006-08-07 21:28:00 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux. Red Hat
Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more timely manner.
However, the issues listed in these bugs are in packages that are no longer
shipped in a current Fedora Core release. Hence, we are closing these bugs CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.