Bug 107618 - [rfe] [patch] host/hrSensor back!
Summary: [rfe] [patch] host/hrSensor back!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-21 10:50 UTC by Kaj J. Niemi
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 10:58:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
difference between 5.0.9-2 and 5.0.9-3 spec file (1.54 KB, patch)
2003-10-21 10:52 UTC, Kaj J. Niemi
no flags Details | Diff
Patch adding support for sensors to net-snmp 5.x (13.42 KB, patch)
2003-10-21 10:54 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2003-10-21 10:50:33 UTC
Please accept this relatively tested patch which merges the following for
net-snmp 5.x (diffs against 5.0.9-2 from Rawhide):

- the original sensors patch Harald Hoyer <harald@redhat.com> once wrote for
UCD-SNMP 4.1.x
- Ben Woodard's <woodard@redhat.com> sensors conditional dlopen() patch (bug #69125)
- Buildprereq rpm-devel (5.0.9-2 changelog talks about rpm-devel but looking at
bug (#103892) this should be net-snmp-devel and this patch is unnecessary and
the changelog in error)

I've verified this to work under the following conditions:

- various servers with an I2c subsystem and lm_sensors configured
  with sensors-detect
- various servers without any lm_sensors package at all
- an IBM laptop with lm_sensors installed but not active


The original artistic style has been preserved for all eternity (or at least the
next indent -kr ;-))


Steps to Reproduce:
1. Apply patches
2. rebuild
3. make sure lm_sensors is properly installed to verify sensors support
4. go root
5. restart net-snmp
6. lsof -p `cat /var/run/snmpd` |grep sens
snmpd   31234 root  mem    REG        3,2   102408   66061
/usr/lib/libsensors.so.2.0.0
snmpd   31234 root    8r   REG        3,1    48520   34611 /etc/sensors.conf
7. snmpwalk -v 2c -c community 127.0.0.1 host.8 (or similar)
(( lots of output ))


I believe there is a demand for this feature and since this was released as
ERRATA for 7.x it might as well be integrated into the new snmpd as well.

Comment 1 Kaj J. Niemi 2003-10-21 10:52:07 UTC
Created attachment 95341 [details]
difference between 5.0.9-2 and 5.0.9-3 spec file

Comment 2 Kaj J. Niemi 2003-10-21 10:54:26 UTC
Created attachment 95342 [details]
Patch adding support for sensors to net-snmp 5.x

Comment 3 Phil Knirsch 2003-10-21 11:11:06 UTC
That certainly looks nice. I'll be including it the next build.

Thanks!

Read ya, Phil

Comment 4 Phil Knirsch 2003-11-19 10:58:43 UTC
Again, thanks for the patch!

It's included now in net-snmp-5.1-1 which should hit the stree erh,
rawhide i mean in the next few days.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.