Bug 107715 - /sbin/modutils -c segfaults when run as normal user on 2.6
Summary: /sbin/modutils -c segfaults when run as normal user on 2.6
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: modutils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-22 13:19 UTC by Ralf Ertzinger
Modified: 2014-03-17 02:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-09 12:00:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modprobe backtrace (truncated, goes on line this for ~150 lines total) (774 bytes, text/plain)
2004-01-29 15:52 UTC, Ralf Ertzinger
no flags Details
modprobe.conf (789 bytes, text/plain)
2004-01-29 16:35 UTC, Ralf Ertzinger
no flags Details
modprobe.conf.dist (6.12 KB, text/plain)
2004-01-29 16:36 UTC, Ralf Ertzinger
no flags Details

Description Ralf Ertzinger 2003-10-22 13:19:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
When running "/sbin/modprobe -c" as a normal user (kernel-2.6.0-0.test8.1.63),
modprobe segfaults.

It runs fine as root.

Since the binary is not compiled with debugging symbols,
there is not much to be seen in strace or gdb.

Version-Release number of selected component (if applicable):
modutils-2.4.25-13

How reproducible:
Always

Steps to Reproduce:
1. Boot 2.6.0-test kernel
2. Log in as normal user
3. run "/sbin/modprobe -c"
    

Actual Results:  modprobe segfaults

Expected Results:  Show the currently used configuration, or show an error
message (if the command is meant to be run as root only)

Additional info:

Comment 1 Bill Nottingham 2004-01-28 06:19:13 UTC
This works for me with 2.4.26-2. Please reopen if it persists.

Comment 2 Ralf Ertzinger 2004-01-28 12:03:07 UTC
Still segfaults for me.
Any pointer to a document explaining how to use the -debuginfo
packages to get the debugging symbols back would be highly appreciated.
Thanks.

Comment 3 Bill Nottingham 2004-01-28 17:41:59 UTC
Just install modutils-debuginfo, and run modprobe under gdb.

Comment 4 Ralf Ertzinger 2004-01-29 15:52:21 UTC
Created attachment 97335 [details]
modprobe backtrace (truncated, goes on line this for ~150 lines total)

Comment 5 Ralf Ertzinger 2004-01-29 15:52:55 UTC
OK, things are getting stranger.
Running /sbin/modprobe in an xterm or at the console works just fine.
Starting a screen and running modprobe in it causes modprobe to segfault.

gdb says:

(gdb) run -c
Starting program: /sbin/modprobe -c

Program received signal SIGSEGV, Segmentation fault.
0x080593e5 in gather_options (argv=0xfeeb1e78) at modprobe.c:1098
1098                    if (strchr(*argv, ' ')) {


The backtrace is... interesting. Attached.

Comment 6 Bill Nottingham 2004-01-29 16:26:45 UTC
Can you attach your /etc/modprobe.conf and /etc/modprobe.conf.dist?

Comment 7 Ralf Ertzinger 2004-01-29 16:35:36 UTC
Created attachment 97338 [details]
modprobe.conf

Comment 8 Ralf Ertzinger 2004-01-29 16:36:27 UTC
Created attachment 97339 [details]
modprobe.conf.dist

Comment 9 Bill Nottingham 2004-01-29 16:50:44 UTC
Ah, it's screen that's the trigger. Looking at it.

Comment 10 Ralf Ertzinger 2004-04-09 12:00:18 UTC
Works now with screen-4.0.2-1 and modutils-2.4.26-14.


Note You need to log in before you can comment on or make changes to this bug.