Bug 10772 - ipx_configure in IPX utils and NCPFS cannot run
ipx_configure in IPX utils and NCPFS cannot run
Status: CLOSED DUPLICATE of bug 10375
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-12 21:20 EDT by keithharris
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-12 21:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description keithharris 2000-04-12 21:20:22 EDT
I'm having problems getting ipx_configure to work after installing RH6.2 I
used to have 6.0 on this machine, and it worked fine. I need it to access
NetWare volumes and printers.

When you execute ipx_configure, it gives you the error "ipx_configure:
socket: Invalid argument". I have removed ipxutils and ncpfs, tried using
older versions (from 6.1), and tried using ipxutils 2.2.0.17-4 (RH6.2 ships
version 2.2.0.17-3), and all of them have the same problem.

I have tried the following commands (all as root of course)
ipx_configure
ipx_configure --auto_primary=on --auto_interface=on
ipx_interface check eth0 802.2
All give the same response "socket: invalid argument"

I have also tried using Linuxconf to activate the changes, suid root
ipx_configure, but to no avail.

Looking in /proc/net, there is no ipx* stuff, and I don't know if that's
because I can't ipx_configure. All IP related networking is working fine -
full access to the Internet, NFS, NIS, DNS, etc.

Was something changed somewhere else that broke ipxutils? Hope someone can
look into this becuase I can't roll out 6.2 to the rest of the servers
until this stuff is fixed, my users depend on it... Thanks in advance!
Comment 1 Bill Nottingham 2000-04-12 21:31:59 EDT
The modutils that shipped with 6.2 accidentally did not
have the proper aliases defined for the IPX and Appletalk modules.

This is fixed in the modutils package currently in Raw Hide.

(In the meantime, you can always do 'modprobe ipx' manually before
running ipx_configure...)

*** This bug has been marked as a duplicate of 10375 ***

Note You need to log in before you can comment on or make changes to this bug.