Bug 1077259 - [GSS] (6.3.0) HttpServletRequestSnapshot is not created for requests with WSA ReplyTo prop set
Summary: [GSS] (6.3.0) HttpServletRequestSnapshot is not created for requests with WSA...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER4
: EAP 6.3.0
Assignee: Alessio Soldano
QA Contact: Rostislav Svoboda
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1077262 1077263 1087653 1103627
TreeView+ depends on / blocked
 
Reported: 2014-03-17 15:17 UTC by Kyle Lape
Modified: 2018-12-05 17:43 UTC (History)
3 users (show)

(edit)
A bug previous releases of JBoss EAP 6 prevented HttpServletRequestSnapshot from being created for requests with WS-Addressing enabled and the ReplyTo header property specified to a non generic address.

This bug resulted in an immediate HTTP 202 response and the servlet request being early recycled by the container. This prevented endpoints from accessing the servlet request context information.

The issue has been resolved in this release of the product by an upgrade to the CXF component.
Clone Of:
: 1077262 (view as bug list)
(edit)
Last Closed: 2014-06-28 15:26:59 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA CXF-5116 None None None Never
Apache JIRA CXF-5602 None None None Never
JBoss Issue Tracker JBWS-3773 Major Closed HttpServletRequest in WebServiceContext and requests with WSA ReplyTo prop set 2017-03-29 14:46 UTC

Description Kyle Lape 2014-03-17 15:17:32 UTC
When using Apache CXF (through JBossWS integration) on top of JBoss AS 7 (whose web layer is based on JBoss Web, basically a fork of Tomcat), I'm still seeing the defect previously dealt with in https://issues.apache.org/jira/browse/CXF-2911 . This time, however, the MEP is not oneway, but a request-response one with WS-Addressing enabled and the ReplyTo header property specified to a non generic address.
The net effect is that a HTTP 202 response is immediately dispatched to the caller, letting Tomcat recycle the underlying httpservlet request.

Comment 1 Kyle Lape 2014-03-24 22:10:29 UTC
CXF-5602 is sort-of dependent on CXF-5116, so I'm adding it here.

Comment 2 Scott Mumford 2014-04-22 23:55:16 UTC
Flagged as Known Issue as ticket unresolved at the time of writing the release note.

Comment 4 JBoss JIRA Server 2014-04-23 10:20:21 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3773 to Resolved

Comment 5 Kabir Khan 2014-04-23 14:00:46 UTC
Solved by update https://bugzilla.redhat.com/show_bug.cgi?id=1087653

Comment 6 Kabir Khan 2014-04-25 15:19:45 UTC
Moving to ER4 since ER3 is the new beta candidate, and is ER2+beta blockers only

Comment 8 Jan Blizňák 2014-05-22 11:48:35 UTC
Verified on 6.3.0.ER4

I verified that reproducers from customer case test the problem.
I tried to run them with results:

all failed on 6.3.0.ER3
all passed on 6.3.0.ER4

I also checked that all fixes for CXF-5602 and CXF-5116 are really included in CXF 2.7.11

Comment 9 JBoss JIRA Server 2015-04-25 20:30:14 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3773 to Closed


Note You need to log in before you can comment on or make changes to this bug.