Bug 107768 - RFE: Decent error message when up2date can't reach repo
Summary: RFE: Decent error message when up2date can't reach repo
Status: CLOSED DUPLICATE of bug 107732
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-22 19:58 UTC by Doug Stewart
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doug Stewart 2003-10-22 19:58:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
Rawhide downtime has caused a nasty user-unfriendly condition to crop up in
up2date.  When a repo can't be reached, a mess of Python errors are spewed to
the terminal and up2date-gnome proceeds to "Packages Marked to Skip" dialog, yet
the progress dialog just hangs indefinitely.

Such a condition should produce a dialog similar to the one that up2date
produces when no updates are available.

Version-Release number of selected component (if applicable):
up2date-4.1.7-1

How reproducible:
Always

Steps to Reproduce:
1. Run up2date when main yum repo is unavailable
2. Watch for Python errors and lack of dialog
3. Rinse, repeat
    

Actual Results:  Nasty Python messages written to terminal, no dialog produced.

Expected Results:  A dialog informing the user of something to the extent of
"I'm sorry.  I can't reach that repository" should be printed and no Python
errors should go to STDOUT/STDERR.

Additional info:

Comment 1 Bill Nottingham 2003-10-22 20:43:02 UTC

*** This bug has been marked as a duplicate of 107732 ***

Comment 2 Adrian Likins 2003-10-23 19:16:24 UTC
available in 4.1.9/10 when rawhide comes back

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.