Bug 107732 - up2date hangs if rawhide disabled
up2date hangs if rawhide disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 107768 107793 107833 107837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 11:15 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 16:14:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New Traceback (1.69 KB, text/plain)
2003-10-23 16:00 EDT, Max Kanat-Alexander
no flags Details

  None (edit)
Description Gene Czarcinski 2003-10-22 11:15:19 EDT
Description of problem:
With the recent disabling of rawhide (for reorganization), it revealed a problem
with up2date:  it does not "properly" handle the un-availability of rawhide
(missing or not readable).  Rather than "hanging" trying to access rawhide,
there should be better error handling (perhaps a timeout is needed) and a
message issued.
Comment 1 Bill Nottingham 2003-10-22 11:43:29 EDT
This must be the GUI that hangs? The CLI tracebacks.
Comment 2 Gene Czarcinski 2003-10-22 12:03:31 EDT
yes, the gui interface
Comment 3 Gene Czarcinski 2003-10-22 12:05:52 EDT
I tried the cli and yes it tracebacks.  However, I believe that something like
up2date needs to be a bit more bullet-proof for users and issue more meaningful
error messages.
Comment 4 Barry K. Nathan 2003-10-22 14:02:54 EDT
The GUI freeze is most likely a dupe of bug 88349.

AFAICT the CLI traceback is happening on the URL:
<http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info>
It gives me a "403 Forbidden" error when I try to visit it in a web browser, BTW.
(Just mentioning this in case this helps to fix the traceback.)
Comment 5 Bill Nottingham 2003-10-22 16:43:05 EDT
*** Bug 107768 has been marked as a duplicate of this bug. ***
Comment 6 Robert Myers 2003-10-23 00:30:29 EDT
Can't even register new installation of Severn 3.  Wouldn't have a clue without
ethereal.  I'm really just assuming that I'm having the same problem as everyone
else.  I don't really *know* that this is a duplicate.

0000  3c 21 44 4f 43 54 59 50 45 20 48 54 4d 4c 20 50   <!DOCTYPE HTML P
0010  55 42 4c 49 43 20 22 2d 2f 2f 49 45 54 46 2f 2f   UBLIC "-//IETF//
0020  44 54 44 20 48 54 4d 4c 20 32 2e 30 2f 2f 45 4e   DTD HTML 2.0//EN
0030  22 3e 0a 3c 48 54 4d 4c 3e 3c 48 45 41 44 3e 0a   ">.<HTML><HEAD>.
0040  3c 54 49 54 4c 45 3e 34 30 33 20 46 6f 72 62 69   <TITLE>403 Forbi
0050  64 64 65 6e 3c 2f 54 49 54 4c 45 3e 0a 3c 2f 48   dden</TITLE>.</H
0060  45 41 44 3e 3c 42 4f 44 59 3e 0a 3c 48 31 3e 46   EAD><BODY>.<H1>F
0070  6f 72 62 69 64 64 65 6e 3c 2f 48 31 3e 0a 59 6f   orbidden</H1>.Yo
0080  75 20 64 6f 6e 27 74 20 68 61 76 65 20 70 65 72   u don't have per
0090  6d 69 73 73 69 6f 6e 20 74 6f 20 61 63 63 65 73   mission to acces
00a0  73 20 2f 70 75 62 2f 72 65 64 68 61 74 2f 6c 69   s /pub/redhat/li
00b0  6e 75 78 2f 72 61 77 68 69 64 65 2f 2f 68 65 61   nux/rawhide//hea
00c0  64 65 72 73 2f 68 65 61 64 65 72 2e 69 6e 66 6f   ders/header.info
00d0  0a 6f 6e 20 74 68 69 73 20 73 65 72 76 65 72 2e   .on this server.
Comment 7 Gene Czarcinski 2003-10-23 12:43:12 EDT
*** Bug 107833 has been marked as a duplicate of this bug. ***
Comment 8 Adrian Likins 2003-10-23 15:15:38 EDT
*** Bug 107837 has been marked as a duplicate of this bug. ***
Comment 9 Max Kanat-Alexander 2003-10-23 16:00:28 EDT
Created attachment 95445 [details]
New Traceback

The latest up2date seems to change the location of the freeze for me. Now it
freezes slightly differently with the progress dialog, displaying: "Fetching
RPM header: Xbae 4.50.2-2"

Note that the only way that I was able to get the latest up2date was by
compiling it from the SRPM in rpmfind.

I've attached the traceback (I ran the gui from the gnome-terminal).

Is this the same bug, or somehow similar, or a different one entirely?

-M
Comment 10 Adrian Likins 2003-10-23 16:27:23 EDT
Max K-A:
   which new version?

4.1.10 seems to just throw up an error window indicating
a 403 error. 
Comment 11 Adrian Likins 2003-10-23 16:36:47 EDT
Max K-A:
   which new version?

nm, 4.1.9 seems to cause that, 4.1.10 has the fix. 
Comment 12 Bill Nottingham 2003-10-23 21:12:53 EDT
*** Bug 107793 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.