Bug 1077703 - enigma bundles lua
enigma bundles lua
Status: NEW
Product: Fedora
Classification: Fedora
Component: enigma (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
: Reopened
Depends On: 1178939
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-03-18 08:53 EDT by Ville Skyttä
Modified: 2016-07-26 00:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 07:11:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2014-03-18 08:53:52 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

enigma bundles enet and lua. Fixing both takes a bit of work because simply using system enet instead of the bundled one will cause the build to fail, and ditto probably lua which may need some tweaking because it's 5.1 which is lua-devel on Fedora < 20 and EPEL, and compat-lua-devel on F-20+.

It also bundles zipios++ but that's taken care of in #1077702
Comment 1 Michal Schmidt 2015-01-05 12:16:21 EST
enigma-1.21's configure script has an option "--with-system-enet". I'll try using it after bug 1178939 is fixed.
Comment 2 Michal Schmidt 2015-01-06 08:14:39 EST
enet unbundled in enigma-1.21-2.fc22.
Comment 3 Jaroslav Reznik 2015-03-03 10:36:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 4 Fedora End Of Life 2016-07-19 07:11:03 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 5 Jan Kurik 2016-07-26 00:48:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Note You need to log in before you can comment on or make changes to this bug.