Bug 107790 - redhat-config-xfree86 doesnt work when i click 'ok'
redhat-config-xfree86 doesnt work when i click 'ok'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 107443 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 22:42 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 14:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick patch (650 bytes, patch)
2003-10-22 22:49 EDT, Jonathan Blandford
no flags Details | Diff

  None (edit)
Description Dams 2003-10-22 22:42:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1) Gecko/20031014
Galeon/1.3.9

Description of problem:
redhat-config-xfree86 seems to work everywhere very fine except when i click on
the 'ok' button.

Version-Release number of selected component (if applicable):
redhat-config-xfree86(0:0.9.13-1).noarch

How reproducible:
Always

Steps to Reproduce:
1. redhat-config-xfree86

Actual Results:  [root@gruyere /etc/apt]#  redhat-config-xfree86
 
(xconf.py:20614): Gdk-WARNING **: DESKTOP_STARTUP_ID contains invalid UTF-8
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds


Additional info:

I tried with --reconfig and it didnt worked either.
BTW this message : 
(xconf.py:20614): Gdk-WARNING **: DESKTOP_STARTUP_ID contains invalid UTF-8
is unrelated with the bug, and it doesnt appear if i set locale to fr_FR.UTF-8.

I got a Radeon 7200 video card : 
-
class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Radeon 7200
desc: "ATI|Radeon R100 QD [Radeon 7200]"
vendorId: 1002
deviceId: 5144
subVendorId: 1002
subDeviceId: 0038
pciType: 1
pcibus:  1
pcidev:  5
pcifn:  0

The monitor is currently configured as generic 1600x1200 monitor.
(I got a mitsubishi diamond 230sb which is not in the list).
Comment 1 Jonathan Blandford 2003-10-22 22:49:07 EDT
I get this too, Brent.  Here's a really lame patch that bandaids over the problem.
Comment 2 Jonathan Blandford 2003-10-22 22:49:50 EDT
Created attachment 95413 [details]
Quick patch
Comment 3 Brent Fox 2003-10-23 14:47:44 EDT
That patch doesn't really fix the problem.  I've committed a fix, which should
appear in redhat-config-xfree86-0.9.14-1.
Comment 4 Brent Fox 2003-10-23 16:11:35 EDT
*** Bug 107443 has been marked as a duplicate of this bug. ***
Comment 5 Elton Woo 2003-10-24 14:52:36 EDT
When will redhat-config-xfree86-0.9.14-1 be available? I've just checked
up2date/rawhide, and nothing (14:53 EST). The most recent version I have is
redhat-config-xfree86-0.9.13-1, and the problem still persists: no action
from the Display Manager.
Comment 6 Brent Fox 2003-10-24 15:28:58 EDT
Rawhide seems to be down at the moment.  Try downloading from
ftp://people.redhat.com/bfox/redhat-config-xfree86-0.9.15-1.noarch.rpm
Comment 7 Elton Woo 2003-10-24 16:07:41 EDT
Got it and installed it (~xfree86-0.9.15-1.noarch). It works, but no longer "on
the fly" you have to logout, and it no longer asks you if you want to test the 
selected configuration, or accept it... :-(
Comment 8 Brent Fox 2003-10-29 16:57:14 EST
Elton, redhat-config-xfree86 never worked "on the fly".  It can't.  It has to
modify the /etc/X11/XF86Config file, which is only processed by XFree86 at
runtime.  Any changes to the file require XFree86 to be restarted to take effect.

Note You need to log in before you can comment on or make changes to this bug.