Bug 107443 - redhat-config-xfree fails to run (i.e. does not do *anything*).
redhat-config-xfree fails to run (i.e. does not do *anything*).
Status: CLOSED DUPLICATE of bug 107790
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-18 02:23 EDT by Elton Woo
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-10-18 02:23:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
After installing the latest kernel and updates via up2date (yum-rawhide), The
Display Settings loads from the menu, but does not
activate any changes. When run from a console window, this is the output:

]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
                          [REM: after clicking on "ok" then this shows: --->]

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

NOTE: The monitor cannot be probed since it is an older Viewsonic 17
("non-DDC") model.
AGP Jaton 3D video card (32 Mb) nVidia TNT chip.

versions: 
kernel-2.4.22-1.2096.nptl
XFree86-4.3.0-40
redhat-config-xfree86-0.9.13-1

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.13-1

How reproducible:
Always

Steps to Reproduce:
1. Load the Display manager from the menu or from a root console
2. Change any setting: e.g. resolution, or depth.
3. Click OK
    

Actual Results:  Nothing happens. The gui interface just sits there.

Expected Results:  Message such indicating that changes will take effect, etc.,
should appear, with the choice of accepting or reverting to previous defaults.

Additional info:

After installing the new kernel, and as usual, I recomplied the nVidia
drivers with the usual: export CC=gcc32. System is running at 1024 x 768
resolution, 24-bit. Display manager shows that the maximum availalble is
1600 x 1200, but selecting anything other (higher or lower) than 1024 x
768 has no effect ... not even changing the present resolution to a lower colour
depth.
Comment 1 Mike Chambers 2003-10-19 20:21:09 EDT
Doesn't work for me either, using an ATI 9000 Pro on a KDS monitor.
Comment 2 Michael Schwendt 2003-10-20 03:29:38 EDT
My monitor is a DDC probe capable Samsung Syncmaster 950p+.

I ran into this when I noticed that my screen resolution is 1024x768 instead of
1280x1024. Upon running redhat-config-xfree86 in X it didn't do anything when
clicking "OK". Hence I started it with option "--reconfig" from terminal (and
later run-level 3) and got:

/usr/share/redhat-config-xfree86/redhat-config-xfree86: line 2:  2161
Segmentation fault      python2.2 /usr/share/redhat-config-xfree86/xconf.py $@

After re-running kudzu which I have had disabled, redhat-config-xfree86 starts
at least, but for every click on "OK" it prints the same traceback as already
posted:

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

> XFree86 Version 4.3.0 (Fedora Core 1: 4.3.0-40)
> OS Kernel: Linux version 2.4.22-1.2097.nptl (bhcompile@porky.devel.redhat.com)
> (gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-6)) #1 Fri Oct 17 15:18:02
> EDT 2003 
Comment 3 Bojan Smojver 2003-10-23 00:05:12 EDT
Another similar scenario on an HP-ZE4201 notebook with Radeon IGP follows:

* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "usr/share/redhat-config-xfree86/xConfigDialog.py", line 397, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size
Comment 4 Brent Fox 2003-10-23 15:03:18 EDT
For those that are seeing the following traceback:

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

this is a different bug than what was originally reported.  Please refer to bug
#107790.
Comment 5 Brent Fox 2003-10-23 16:11:33 EDT
Resolving as a dupe of bug #107790.

*** This bug has been marked as a duplicate of 107790 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.