This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 107793 - up2date fails to download noarch packages
up2date fails to download noarch packages
Status: CLOSED DUPLICATE of bug 107732
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 23:07 EDT by Peter Robinson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2003-10-22 23:07:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014
Epiphany/1.0.1

Description of problem:
up2date when running from a yum mirror - planetmirror in australia in particular
(not sure if it happens elsewhere) fails to get the noarch packages such as
caching-nameserver but instead just hangs. in the console from which up2date is
run there's a python/http error 404 stating the file is not found, yet when
browsing to the repository the file is indead there. up2date just hangs and
doesn't deal with the error. The files can be downloaded with manually with
ftp/http and installed with no problem. Errors included below.

yum rawhide http://public.www.planetmirror.com.au/pub/redhat/redhat-rawhide/

[root@trinity root]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1871, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 180, in getPackage
    buffer = rpcServer.doCall(repos.getPackage, pkg, msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 109, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 35, in getPackage
    return self.handlers[channel['type']].getPackage(pkg, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 183, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 130, in
getPackage
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 257, in
fetchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 98, in
open_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 824, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.2/urllib2.py", line 818, in do_open
    return self.parent.error('http', req, fp, code, msg, hdrs)
  File "/usr/lib/python2.2/urllib2.py", line 348, in error
    result = self._call_chain(*args)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 41, in
http_error_404
    infourl = urllib2.HTTPDefaultErrorHandler.http_error_default(self, req, fp,
code, msg, headers)
  File "/usr/lib/python2.2/urllib2.py", line 406, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found


Version-Release number of selected component (if applicable):
up2date-4.1.7-1

How reproducible:
Always

Steps to Reproduce:
1. set repository within the /etc/sysconfig/rhn/sources config file. 
2. run up2date from command prompt and select all packages to upgrade
3. up2date will hang on any/all noarch packages with errors in console.

Actual Results:  up2date hung

Expected Results:  download and install all packages

Additional info:
Comment 1 Douglas Furlong 2003-10-23 13:09:06 EDT
Okay, this appears to be a duplicate.
Now lets see if I can mark this as a duplicate...

In that case, this is a dup for 107732
Comment 2 Douglas Furlong 2003-10-23 13:09:30 EDT
duplicate 107732
Comment 3 Bill Nottingham 2003-10-23 21:12:52 EDT

*** This bug has been marked as a duplicate of 107732 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.