Bug 107837 - up2date fails on updating packages
up2date fails on updating packages
Status: CLOSED DUPLICATE of bug 107732
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 12:59 EDT by Douglas Furlong
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Furlong 2003-10-23 12:59:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Description of problem:
When running up2date, at least 2 our of 3 attempts will fail, with the below out
put on the command line.

----------OUT PUT----------------
[root@wibbit root]# up2date -u

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 58, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 117, in run
  File "rhnPackageInfo.py", line 315, in getAvailableAllArchPackageList
  File "rhnPackageInfo.py", line 153, in availablePackageList
  File "rpcServer.py", line 109, in doCall
  File "repoDirector.py", line 20, in listPackages
  File "rpmSource.py", line 226, in listPackages
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 197, in
listPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 270, in
fetchUrl
    buffer = readFDBuf(fh, progressCallback) 
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 240, in
readFDBuf
    size = get_size(fd)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line 231, in
get_size
    return long(size)
TypeError: long() argument must be a string or a number
----------OUT PUT----------------

When up2date -u succeeds, and provides a list of updates, the following error
message appears at the end

----------OUT PUT----------------
[root@wibbit root]# up2date -u

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################

Fetching Obsoletes list for channel: rawhide...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
htmlview                                2.0.0          11                  noarch
librsvg2                                2.4.0          2                   i386  
librsvg2-devel                          2.4.0          2                   i386  
rsh                                     0.17           19                  i386  
sane-frontends                          1.0.11         3                   i386  
vorbis-tools                            1.0            7                   i386  
xawtv                                   3.88           6                   i386  


Testing package set / solving RPM inter-dependencies...
There was some sort of I/O error: Not a gzipped file
----------OUT PUT----------------

On performing a wget on the URL provided at the top of the error, the following
out put is given (when the erorr occurs)

----------OUT PUT----------------
[root@wibbit root]# wget
http://ftp.redhat.com/pub/redhat/linux/rawhide/headers/header.info
--17:58:03--  http://ftp.redhat.com/pub/redhat/linux/rawhide/headers/header.info
           => `header.info.1'
Resolving ftp.redhat.com... done.
Connecting to ftp.redhat.com[66.187.224.51]:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
17:58:04 ERROR 403: Forbidden.
----------OUT PUT----------------

It appears that their is a problem with the server providing the header.info and
up2date is not dealing with it gracefully.

I beleive when running the gui version of up2date, it causes the gui to
apparently hang when retrieving information, the only solution is to close it
clicking on the X (not a big problem).

If attempting up2date repeatedly it is possible to update packages.

Doug

Version-Release number of selected component (if applicable):
up2date-4.1.9-1

How reproducible:
Sometimes

Steps to Reproduce:
1.Run up2date several times in a row
2.
3.
    

Actual Results:  an error message is thrown back at times.

Expected Results:  Up2date would display a list of packages, or update the
package selected.

Additional info:
Comment 1 Gene Czarcinski 2003-10-23 13:54:09 EDT
This is a dup of 107732.  Although ftp rawhide is open, http access to rawhide
is still "403 Forbidden" and thus up2date will continue to fail until this is fixed.
Comment 2 Adrian Likins 2003-10-23 15:15:36 EDT

*** This bug has been marked as a duplicate of 107732 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.