Bug 107849 - RFE: Cups should support printer aliases
RFE: Cups should support printer aliases
Status: CLOSED DUPLICATE of bug 91674
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 15:12 EDT by Aaron Whiteman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Whiteman 2003-10-23 15:12:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1)
Gecko/20030306 Camino/0.7

Description of problem:
Under redhat 7.x, using lprNG, we were able to use multiple names for a single
printer.  We had to do this for backwards compatibility and to provide
meaningful names for our users, while simultaneously providing cryptic names
that describe the location of the printer (mandated naming policy).

Thus, a single Panasonic printer could be called both "serodot" and "pbu255h-a".

When exporting the printer database to XML, these secondary names are stored and
used to generate /etc/printcap as appropriate (and everything works).

Under redhat 9, we do not get the aliases.  As far as we can tell, the database
is still storing this information, but CUPS is certainly not seeing it.

The workaround is to create full printer entries for each alias, amounting to
well over 200 "printers".

It would be nice if CUPS could handle aliases, or as an alternative, printtool
creates the printers for us (we don't care if CUPS has 200+ printers, as long as
the redhat tools don't force US to deal with it).   Is this possible?

Version-Release number of selected component (if applicable):
cups-1.1.17-13

How reproducible:
Always

Steps to Reproduce:
1. Create printer using printconf with aliases on system with lprng (we used
rh7.2 and rhes2.1)
2. printconf-tui --Xexport > settings.xml
3. on CUPS-based system (rh9 in our case), printconf-tui --Ximport < settings.xml
4. lpq -P<alias>
    

Actual Results:  the printer is not found

Expected Results:  queue listed for printer described by alias

Additional info:
Comment 1 Tim Waugh 2003-10-23 16:42:45 EDT

*** This bug has been marked as a duplicate of 91674 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.