Bug 91674 - unable to add printer aliases
unable to add printer aliases
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
: 97422 107849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 21:53 EDT by Michael Wardle
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2003-05-26 21:53:31 EDT
The Red Hat printer configuration tool does not allow a printer alias to be
defined.

This should be possible either using an additional text field or at least by
providing the queue name in the usual printer(|alias)* format.
Comment 1 Tim Waugh 2003-05-27 04:14:59 EDT
I'm not actually sure that cups provides that facility.
Comment 2 Tim Waugh 2003-06-16 12:03:34 EDT
*** Bug 97422 has been marked as a duplicate of this bug. ***
Comment 3 Gerald Teschl 2003-06-16 13:41:09 EDT
Yes, you are right, I could not find this either in cups. 

So I guess there are two solutions:

1) Warn the user about it and remove the alias
2) For each alias set up a new queue which spool to the original one

Probably 1) is better.
Comment 4 Denice 2003-09-22 07:47:52 EDT
Its a bit of a shame, really.  Looking at the generated printers.conf file, it
is easy to imagine added a field named 'aliases' for each defined printer and
then allowing config tools to plonk alternate names in this field.

I took a quick look through the source code to see how miserable a change this
would be.. well, there are lots of subsystems that would need changes.  But the
code seems pretty clean, and is easy to understand..
Comment 5 Tim Waugh 2003-10-23 16:42:47 EDT
*** Bug 107849 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2003-11-24 19:41:16 EST
This bug also exists in RHEL3

RHEL3 will allow you to add aliases - however they will not work.

not exactly the behaviour i'd expect from a "enterprise" system.

any idea if fixing this (so aliases work) is likely to be done for RHEl3

Comment 7 Steve Simmons 2004-09-24 09:25:59 EDT
Found this useful item via google:

------------------------------------------------------------------

Re: cups printer aliases

    * From: Ian Mortimer <ian physics uq edu au>
    * To: fedora-list redhat com
    * Subject: Re: cups printer aliases
    * Date: Tue, 23 Dec 2003 14:09:35 +1000

> Anyone know if there any sign of cups supporting printer aliases in the
> near future?
> 
> I have come across:
> 
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91674
> 
> which seems to indicate a glimmer of hope.

There's a trick you can use:  create a printer class with the
alias name and add the printer to the class.

-- 
Ian

------------------------------------------------------------------

Now to see if I can create classes via RH config utils.
Comment 8 RHEL Product and Program Management 2007-10-19 15:36:02 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.