Bug 1078547 - [BUG] [RHEV 3.3] SPICE console not opening in full screen or detecting resolution by default
Summary: [BUG] [RHEV 3.3] SPICE console not opening in full screen or detecting resolu...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.3.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: nobody nobody
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Keywords:
Depends On: 1076243
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-19 21:32 UTC by Jonathon Jongsma
Modified: 2019-05-20 11:12 UTC (History)
12 users (show)

(edit)
Clone Of: 1076243
(edit)
Last Closed: 2014-03-19 22:03:08 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 787578 None CLOSED [RFE] - PRD33 add support for multiple monitors on QXL device (single device with more RAM) 2018-10-11 17:10 UTC

Description Jonathon Jongsma 2014-03-19 21:32:35 UTC
+++ This bug was initially created as a clone of Bug #1076243 +++

Description of problem:
1. From the UserPortal, with the "Full screen" checkbox enabled, a 2nd display did not enable automatically as it should by default. Selecting "2" from the Displays menu on Remote Viewer was required.

2. After manually enabling the 2nd display, that display did not auto-sense the proper screen resolution.

Version-Release number of selected component (if applicable):
RHEV 3.3.1
RHEL 6.5 guest
SPICE Console

How reproducible: 100%


Steps to Reproduce:
1. Log into UserPortal
2. Check the Full Screen checkbox 
3. Open a VM
4. The second display does not appear automatically

Actual results:
The second display must be manually enabled and the screen resolution is not as it should be set.

Expected results:
The second display appears in full screen 

Additional info:

--- Additional comment from Marc-Andre Lureau on 2014-03-13 18:51:02 EDT ---

please reconsider severity/priority...

--- Additional comment from Marian Krcmarik on 2014-03-14 07:44:02 EDT ---

Robert,

what is the launch method Browser plugin/Native and what client OS is used?
There were some bugs I can point you to If I know that.

The important thing for RHEL6.5 guest is to have Spice agent/RHEV agent/QXL driver installed and operational on the guest which means that RHEV agent reports to the RHEVM that QXL driver is installed ont the guest and This can be seen in RHEVM webadmind in Aplllication tab of VM details.

--- Additional comment from Jonathon Jongsma on 2014-03-19 16:18:07 EDT ---

per discussion with byount, it sounds like this is launched in native client mode. The vv file format does not currently have a parameter for specifying auto-conf, so it just uses basic fullscreen mode.  We'd need to add an auto-conf param to the vv file format, and the user portal would have to include that param in its vv-file.

Comment 1 Jonathon Jongsma 2014-03-19 22:03:08 UTC
Sorry for cloning this bug too quickly.  We will try to handle this issue entirely in virt-viewer (e.g. enable auto-conf when fullscreen is set in the vv file).  Any changes to user-portal would only be temporary due to bug 1027381.


Note You need to log in before you can comment on or make changes to this bug.