Bug 10786 - Daytime-tcp server is broken
Summary: Daytime-tcp server is broken
Status: CLOSED DUPLICATE of bug 11548
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inetd   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 11545
TreeView+ depends on / blocked
 
Reported: 2000-04-13 11:09 UTC by David Lawrence
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-16 19:46:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Tattersall 2000-04-13 11:09:32 UTC
Using a sample c program from Stevens' "Unix Network Programming"
inetd-0.16-4 does not terminate and leaves tcp session in CLOSE-WAIT
forever.  Replacing inetd with inetd from netkit-base-0.10-29 (RHL 6.0)
the daytime server works properly, and no seessions are left in CLOSE-WAIT.

Comment 1 Derek Tattersall 2000-04-24 12:17:59 UTC
Adding a close(s); after line 266 of builtins.c causes the daytime server to go
to TIME-WAIT state as expected.

Comment 2 Pekka Savola 2000-07-22 21:43:12 UTC

*** This bug has been marked as a duplicate of 11548 ***


Note You need to log in before you can comment on or make changes to this bug.