Bug 11545 - Problems with daytime (internal)
Problems with daytime (internal)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: elale
:
Depends On: 10786
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-20 22:08 EDT by elale
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-16 03:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
daytime/time close-wait problem patch. (469 bytes, patch)
2000-07-16 15:47 EDT, Pekka Savola
no flags Details | Diff

  None (edit)
Description elale 2000-05-20 22:08:03 EDT
I use the service daytime in my private lan with an linux-box as a time
server trugh inetd (internal service daytime - port 13) the definition in
/etc/services is right and the definition in /etc/inetd.conf too, but with
the inetd of inetd-0.16-4.i386.rpm don't work; the same configuration with
the inetd of the netkit-base-0.10-37.i386.rpm works fine. I can send my
files if you wish. Regards
Comment 1 Pekka Savola 2000-07-15 10:18:55 EDT
0.16-4 works for me just fine.

The entry should be:

daytime stream  tcp     nowait  root    internal

Make sure you're not mistaking about UDP/TCP.

---
[root@lokki /root]# telnet localhost daytime
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
Sat Jul 15 17:16:09 2000
^]
telnet> quit
Connection closed.
----

Comment 2 Pekka Savola 2000-07-16 15:46:22 EDT
Actually, this is caused by a small bug in inetd.  It affects both daytime and
time tcp servers.

Inetd has been replaced with xinetd in Rawhide so this is kinda moot point, but
here's a patch (based on #10786) if you're interested.

Comment 3 Pekka Savola 2000-07-16 15:47:19 EDT
Created attachment 1190 [details]
daytime/time close-wait problem patch.

Note You need to log in before you can comment on or make changes to this bug.