Bug 107861 - IOError: Not a gzipped file; ValueError: min() or max() arg is an empty sequence
IOError: Not a gzipped file; ValueError: min() or max() arg is an empty sequence
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-23 16:34 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 09:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-10-23 16:34:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
Running up2date in the background ("up2date &") gave this python traceback:
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1368, in onChannelsPageNext
    self.pkgList = self.pList.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 519, in
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 548, in __skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 569, in __skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 608, in buildHeaderList
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 37, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 42, in __retrievePackage
   hdr, sourceType = rpcServer.doCall(self.repos.getHeader, item)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 109, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 31, in getHeader
    return self.handlers[channel['type']].getHeader(pkg, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 210, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 94, in
getHeader
    hdrBuf = fh.read()
  File "/usr/lib/python2.2/gzip.py", line 156, in read
    self._read(readsize)
  File "/usr/lib/python2.2/gzip.py", line 198, in _read
    self._read_gzip_header()
  File "/usr/lib/python2.2/gzip.py", line 110, in _read_gzip_header
    raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1447, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence
 


Version-Release number of selected component (if applicable):
up2date-4.1.7-1

How reproducible:
Always

Steps to Reproduce:
1. up2date &  ## as root
2. click "Forward" twice
3. wait for a couple of progress dialogs.

Actual Results:  The GUI becomes non-responsive, and the terminal gets the
python traceback.

Expected Results:  GUI remains responsive and delivers up-to-date packages,
without python tracebacks.

Additional info:

Subscribed to yum channel on rawhide.
Comment 1 Paul W. Frields 2003-10-24 08:50:49 EDT
I'm pretty sure this was due to the recent rawhide tree reorganization, to which
we were alerted on fedora-test-list by Mike Harris (thank you, btw). This
problem does not seem to occur currently under up2date-4.1.9-1.
Comment 2 Max Kanat-Alexander 2003-10-29 17:16:28 EST
This is resolved in recent up2date releases. This bug should probably be CLOSED
RAWHIDE.

-M
Comment 3 Chris Ricker 2003-11-05 09:43:09 EST
closing -- fixed in newer releases

Note You need to log in before you can comment on or make changes to this bug.