Bug 107879 - Upgrade kills nautilus
Upgrade kills nautilus
Status: CLOSED DUPLICATE of bug 107875
Product: Fedora
Classification: Fedora
Component: librsvg2 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 19:20 EDT by David Norman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Norman 2003-10-23 19:20:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030917 Firebird/0.6.1+

Description of problem:
I upgraded librsvg2-2.4.0-1 to librsvg2-2.4.0-2 using up2date today. When I
rebooted to the new kernel I also upgraded to, I tried to open my home directory
in nautilus, nautilus crashed. From the prompt I got:

nautilus: relocation error: /usr/lib/librsvg-2.so.2: undefined symbol:
cr_doc_handler_new

When I downgraded back down to librsvg2-2.4.0-1 and librsvg2-devel-2.4.0-1,
nautilus was happy again.

Some nice people in #fedora on freenode reproduced this.

Version-Release number of selected component (if applicable):
librsvg2-2.4.0-2

How reproducible:
Always

Steps to Reproduce:
1. Update to librsvg2-devel-2.4.0-2 and librsvg2-2.4.0-2 with up2date
2. Rebooted
3. Start nautilus

Actual Results:  Nautilus crashed

Expected Results:  Window showing my /home directory

Additional info:

nautilus: relocation error: /usr/lib/librsvg-2.so.2: undefined symbol:
cr_doc_handler_new
Comment 1 Bill Nottingham 2003-10-23 22:05:46 EDT

*** This bug has been marked as a duplicate of 107875 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.